http_proxy_client 1.0.0

  • README.md
  • Installing
  • Versions
  • 30

http_proxy_client

Run package:http through a proxy.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  http_proxy_client: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:http_proxy_client/http_proxy_client.dart';
  
Version Uploaded Documentation Archive
1.0.0 Mar 21, 2017 Go to the documentation of http_proxy_client 1.0.0 Download http_proxy_client 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
30
Learn more about scoring.

We analyzed this package on Oct 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.4

Platforms

Detected platforms: Flutter, other

Primary library: package:http_proxy_client/http_proxy_client.dart with components: io.

Health suggestions

Fix lib/http_proxy_client.dart. (-1 points)

Analysis of lib/http_proxy_client.dart reported 2 hints:

line 5 col 14: The top level variable '_header' isn't used.

line 7 col 14: The top level variable '_responseStart' isn't used.

Maintenance issues and suggestions

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

Package is getting outdated. (-55.34 points)

The package was released 81 weeks ago.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use http_proxy_client.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0
http ^0.11.0 0.11.3+17 0.12.0
Transitive dependencies
async 2.0.8
charcode 1.1.2
collection 1.14.11
http_parser 3.1.3
meta 1.1.6
path 1.6.2
source_span 1.4.1
string_scanner 1.0.4
typed_data 1.1.6
Dev dependencies
angel_common ^1.0.0-beta
test ^0.12.0