http_server 0.9.7

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 96

Utility classes for HTTP server

A set of high-level classes that, together with HttpServer, makes is easier to serve web content.

NOTE: This package only works for server-side or command-line Dart applications. In other words, if the app imports dart:io, it can use this package.

Features and bugs

Please file feature requests and bugs at the issue tracker.

0.9.7

  • Updates to support Dart 2.0 core library changes (wave 2.2). See issue 31847 for details.

0.9.6

  • Updated the secure networking code to the SDKs version 1.15 SecurityContext api

0.9.5+1

  • Updated the layout of package contents.

0.9.5

  • Removed the decoding of HTML entity values (in the form &#xxxxx;) for values when parsing multipart/form-post requests.

0.9.4

  • Fixed bugs in the handling of the Range header

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  http_server: "^0.9.7"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:http_server/http_server.dart';
        
Version Uploaded Documentation Archive
0.9.7 Feb 2, 2018 Go to the documentation of http_server 0.9.7 Download http_server 0.9.7 archive
0.9.6 Aug 18, 2016 Go to the documentation of http_server 0.9.6 Download http_server 0.9.6 archive
0.9.5+1 Nov 24, 2014 Go to the documentation of http_server 0.9.5+1 Download http_server 0.9.5+1 archive
0.9.5 Nov 19, 2014 Go to the documentation of http_server 0.9.5 Download http_server 0.9.5 archive
0.9.4 Nov 17, 2014 Go to the documentation of http_server 0.9.4 Download http_server 0.9.4 archive
0.9.3 Jul 30, 2014 Go to the documentation of http_server 0.9.3 Download http_server 0.9.3 archive
0.9.2+3 Jul 24, 2014 Go to the documentation of http_server 0.9.2+3 Download http_server 0.9.2+3 archive
0.9.2+2 Jul 4, 2014 Go to the documentation of http_server 0.9.2+2 Download http_server 0.9.2+2 archive
0.9.2+1 Jun 27, 2014 Go to the documentation of http_server 0.9.2+1 Download http_server 0.9.2+1 archive
0.9.2 Mar 28, 2014 Go to the documentation of http_server 0.9.2 Download http_server 0.9.2 archive

All 53 versions...

Analysis

We analyzed this package on Apr 23, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.49.0
  • pana: 0.10.6

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
92 / 100
Health:
Code health derived from static analysis. [more]
99 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
96
Learn more about scoring.

Platforms

Detected platforms: Flutter, other

Primary library: package:http_server/http_server.dart with components: io.

Suggestions

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 8 hints.

    Strong-mode analysis of lib/src/http_body.dart gave the following hint:

    line: 111 col: 46
    'UTF8' is deprecated and shouldn't be used.

    Strong-mode analysis of lib/src/http_body_impl.dart gave the following hint:

    line: 147 col: 27
    'UTF8' is deprecated and shouldn't be used.

    Similar analysis of the following files failed:

    • lib/src/http_multipart_form_data.dart (hint)
    • lib/src/virtual_directory.dart (hint)
  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use http_server.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.20.0 <2.0.0
mime >=0.9.0 <0.10.0 0.9.6
path >=0.9.0 <2.0.0 1.5.1
Dev dependencies
unittest >=0.10.0 <0.12.0