http_test_client 0.0.1

  • Installing
  • Versions
  • 51


A package for testing http clients on flutter or the Dart vm.


The following example forces all HTTP requests to return a successful empty response in a test enviornment. No actual HTTP requests will be performed.

class MyHttpOverrides extends HttpOverrides {
  HttpClient() createClient(_) {
    return new HttpTestClient((request, client) {
        // the default response is an empty 200.
        return new HttpTestResponse();

void main() {
  // overrides all HttpClients. = new MyHttpOverrides();

  group('HttpClient', () {
    test('returns OK', () async {
      // this is actually an instance of [HttpTestClient].
      final client = new HttpClient();
      final request = client.getUrl(new Uri.https(''));
      final response = await request.close();

      expect(response.statusCode, HttpStatus.OK);

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  http_test_client: "^0.0.1"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:http_test_client/http_test_client.dart';
Version Uploaded Documentation Archive
0.0.1 Apr 4, 2018 Go to the documentation of http_test_client 0.0.1 Download http_test_client 0.0.1 archive


We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3


Describes how popular the package is relative to other packages. [more]
10 / 100
Code health derived from static analysis. [more]
99 / 100
Reflects how tidy and up-to-date the package is. [more]
80 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: Flutter, other

Primary library: package:http_test_client/http_test_client.dart with components: io.


  • Maintain

    Changelog entries help clients to follow the progress in your code.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use http_test_client.dart.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 2 hints.

    Strong-mode analysis of lib/http_test_client.dart gave the following hint:

    line: 279 col: 48
    'OK' is deprecated and shouldn't be used.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <2.0.0
Dev dependencies
test ^0.12.32