http_throttle 1.0.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 23

http_throttle is middleware for the http package that throttles the number of concurrent requests that an HTTP client can make.

// This client allows 32 concurrent requests.
final client = new ThrottleClient(32);

Future<List<String>> readAllUrls(Iterable<Uri> urls) {
  return Future.wait(urls.map((url) {
    // You can safely call as many client methods as you want concurrently, and
    // ThrottleClient will ensure that only 32 underlying HTTP requests will be
    // open at once.
    return client.read(url);
  }));
}

1.0.1

  • Properly release resources for requests that error out.

1.0.0

  • Initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  http_throttle: ^1.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:http_throttle/http_throttle.dart';
  
Version Uploaded Documentation Archive
1.0.4 Oct 26, 2018 Go to the documentation of http_throttle 1.0.4 Download http_throttle 1.0.4 archive
1.0.3 Jul 16, 2018 Go to the documentation of http_throttle 1.0.3 Download http_throttle 1.0.3 archive
1.0.2 May 19, 2018 Go to the documentation of http_throttle 1.0.2 Download http_throttle 1.0.2 archive
1.0.1 Jun 2, 2017 Go to the documentation of http_throttle 1.0.1 Download http_throttle 1.0.1 archive
1.0.0 Jan 15, 2015 Go to the documentation of http_throttle 1.0.0 Download http_throttle 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
46
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
23
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.17.0 <2.0.0