Over time this should become a collection of useful HTTP-Tools...
If the documentation links don't not work - pls. got to GitHub - there it they'll work
Commonly used status codes defined by HTTP<br> Dart Documentation for ResponseStatus here
Helps you to compose URIs.<br> Dart Documentation for URIBuilder here
http_utils on PUB
Copyright 2017 Michael Mitterer, IT-Consulting and Development Limited, Austrian Branch Licensed under the Apache License, Version 2.0 (the "License"); you may not use this file except in compliance with the License. You may obtain a copy of the License at http://www.apache.org/licenses/LICENSE-2.0 Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License.
If this plugin is helpful for you - please (Circle) me.
Provides some HTTP related classes portet from Apache HTTP client lib
This CHANGELOG.md was generated with Changelog for Dart
Add this to your package's pubspec.yaml file:
dependencies: http_utils: ^1.6.1
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|1.6.1||Jun 4, 2018|
|1.5.4||Dec 13, 2017|
|1.5.1||Dec 7, 2017|
|1.4.2||Nov 16, 2016|
|1.4.1||Nov 16, 2016|
|1.4.0||Dec 4, 2015|
|1.3.2||Oct 3, 2014|
|1.3.1||Oct 1, 2014|
|1.3.0||Oct 1, 2014|
|1.2.10||Feb 13, 2014|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
|Dart SDK||>=1.12.0 <2.0.0|