http_utils 1.5.4

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 71

Over time this should become a collection of useful HTTP-Tools...

If the documentation links don't not work - pls. got to GitHub - there it they'll work

ResponseStatus

Commonly used status codes defined by HTTP<br> Dart Documentation for ResponseStatus here

URIBuilder

Helps you to compose URIs.<br> Dart Documentation for URIBuilder here

For further documentation please refere to the Unit-Tests.<br> ApiDoc for Apaches URIBuilder

HTTPStatus

Brings status-code to a more readable form. Dart Documentation fur HTTPStatus is here (Unit-Tests)

http_utils on PUB

License

Copyright 2017 Michael Mitterer, IT-Consulting and Development Limited,
Austrian Branch

Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
You may obtain a copy of the License at

   http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, 
software distributed under the License is distributed on an 
"AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, 
either express or implied. See the License for the specific language 
governing permissions and limitations under the License.

If this plugin is helpful for you - please (Circle) me.

Change Log for http_utils

Provides some HTTP related classes portet from Apache HTTP client lib

Unreleased

Refactor

  • Preparation for Jenkins, versions constraints 53e6002

v1.4.1 - 2016-11-16

Docs

v1.4.0 - 2015-12-04

Docs

  • Grinder-Support + new test-format 373cb68

This CHANGELOG.md was generated with Changelog for Dart

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  http_utils: "^1.5.4"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:http_utils/http_utils.dart';
        
Version Uploaded Documentation Archive
1.5.4 Dec 13, 2017 Go to the documentation of http_utils 1.5.4 Download http_utils 1.5.4 archive
1.5.1 Dec 7, 2017 Go to the documentation of http_utils 1.5.1 Download http_utils 1.5.1 archive
1.4.2 Nov 16, 2016 Go to the documentation of http_utils 1.4.2 Download http_utils 1.4.2 archive
1.4.1 Nov 16, 2016 Go to the documentation of http_utils 1.4.1 Download http_utils 1.4.1 archive
1.4.0 Dec 4, 2015 Go to the documentation of http_utils 1.4.0 Download http_utils 1.4.0 archive
1.3.2 Oct 3, 2014 Go to the documentation of http_utils 1.3.2 Download http_utils 1.3.2 archive
1.3.1 Oct 1, 2014 Go to the documentation of http_utils 1.3.1 Download http_utils 1.3.1 archive
1.3.0 Oct 1, 2014 Go to the documentation of http_utils 1.3.0 Download http_utils 1.3.0 archive
1.2.10 Feb 13, 2014 Go to the documentation of http_utils 1.2.10 Download http_utils 1.2.10 archive
1.2.9 Feb 13, 2014 Go to the documentation of http_utils 1.2.9 Download http_utils 1.2.9 archive

All 30 versions...

Analysis

This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • completed on Feb 3, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
42 / 100
Health:
Code health derived from static analysis. [more]
99 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
71

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:http_utils/http_utils.dart.

Suggestions

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use http_utils.dart.

  • Use analysis_options.yaml.

    Rename old .analysis_options file to analysis_options.yaml.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.12.0 <2.0.0
intl >=0.15.2 <1.0.0 0.15.2
Transitive dependencies
path 1.5.1
Dev dependencies
browser any
grinder any
test any
validate any