humanhash 1.0.0

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 12

humanhash

A human-readable unique ID generator ported from Docker

Generates names like:

elegant_hugle
sleepy_nightingale
epic_mccarthy
...

optionally with a number:

vigorous_bhaskara6
gallant_brahmagupta4
stoic_keller2
...

Usage

A simple usage example:

import 'package:humanhash/humanhash.dart' as hhash;

main() {
  var name = hhash.getRandomName();
  print(name);
}

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.0.1

  • Initial version, created by Stagehand

example/main.dart

import 'package:humanhash/humanhash.dart' as hhash;

main() {
  for (var i = 0; i < 10; i++) {
    var name = hhash.getRandomName(true);
    print(name);
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  humanhash: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:humanhash/humanhash.dart';
  
Version Uploaded Documentation Archive
1.0.0 Mar 19, 2017 Go to the documentation of humanhash 1.0.0 Download humanhash 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
23
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
12
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0