icu_server 0.0.7

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 42

server

Completion system for Vim

Changelog

0.0.1

  • Initial version, created by Stagehand

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate icu_server

2. Use it

The package has the following executables:


$ icu
Version Uploaded Documentation Archive
0.0.7 Jan 29, 2017 Go to the documentation of icu_server 0.0.7 Download icu_server 0.0.7 archive
0.0.6 Jan 29, 2017 Go to the documentation of icu_server 0.0.6 Download icu_server 0.0.6 archive
0.0.5 Jan 29, 2017 Go to the documentation of icu_server 0.0.5 Download icu_server 0.0.5 archive
0.0.3 Jan 28, 2017 Go to the documentation of icu_server 0.0.3 Download icu_server 0.0.3 archive
0.0.2 Jan 22, 2017 Go to the documentation of icu_server 0.0.2 Download icu_server 0.0.2 archive
0.0.1 Jan 22, 2017 Go to the documentation of icu_server 0.0.1 Download icu_server 0.0.1 archive

Analysis

We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
99 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
61 / 100
Overall score:
Weighted score of the above. [more]
42
Learn more about scoring.

Platforms

Detected platforms: Flutter, other

Platform components identified in package: io.

Suggestions

  • Package is getting outdated.

    The package was released 72 weeks ago.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 13 hints.

    Strong-mode analysis of lib/api/interceptors/allowed_hosts.dart gave the following hint:

    line: 23 col: 22
    'BAD_REQUEST' is deprecated and shouldn't be used.

    Strong-mode analysis of lib/api/interceptors/hmac.dart gave the following hint:

    line: 22 col: 48
    'BASE64' is deprecated and shouldn't be used.

    Similar analysis of the following files failed:

    • lib/api/models/models.dart (hint)
    • lib/filter_and_sort/filter_and_sort.dart (hint)
  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use icu_server.dart.

  • Use analysis_options.yaml.

    Rename old .analysis_options file to analysis_options.yaml.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0
args >=0.13.7 <0.14.0 0.13.7 1.4.3
bit_set >=0.1.0 <0.2.0 0.1.0
crypto >=2.0.0 <3.0.0 2.0.5
dart_analysis_client >=0.0.3 <0.1.0 0.0.3
jaguar >=0.2.6 <0.3.0 0.2.9 2.1.7
path >=1.4.1 <2.0.0 1.6.1
scribe >=0.2.0 <0.3.0 0.2.1
Transitive dependencies
charcode 1.1.1
collection 1.14.10
convert 2.0.1
http_server 0.9.7
intl 0.14.0 0.15.6
logging 0.11.3+1
mime 0.9.6+1
source_span 1.4.0
stack_trace 1.9.2
string_scanner 1.0.2
typed_data 1.1.5
yaml 2.1.14
Dev dependencies
test >=0.12.0 <0.13.0