idle_tracker 0.0.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 23

idle_tracker

A tiny package that tracks idleness in a web application.

Usage

A simple usage example:

import 'package:idle_tracker/idle_tracker.dart';

void main() {
  new IdleTracker(
      timeout: const Duration(seconds: 5),
      periodicIdleCall: true,
      startsAsIdle: true,
      onIdle: () => print('Hey, are you there?'),
      onActive: () => print('Welcome back!'))
    ..start();
}

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.0.1

  • Initial version

example/example.dart

import 'dart:html';

import 'package:idle_tracker/idle_tracker.dart';

void main() {
  new IdleTracker(
      timeout: const Duration(seconds: 5),
      periodicIdleCall: true,
      startsAsIdle: true,
      onIdle: onIdle,
      onActive: onActive)
    ..start();
}

var count = 0;
final output = document.querySelector('#output');

void log(String message) {
  if (output.children.length >= 40) {
    output.innerHtml = '';
  }
  output.append(new DivElement()..text = message);
}

void onActive() {
  count = 0;
  log('Welcome back!');
}

void onIdle() {
  if (count++ < 10) log('Hey, are you there?');
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  idle_tracker: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:idle_tracker/idle_tracker.dart';
  
Version Uploaded Documentation Archive
0.0.1 Dec 2, 2017 Go to the documentation of idle_tracker 0.0.1 Download idle_tracker 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
47
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
23
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0