A flutter package for image carousels.
Supports both Asset and Network images.
new ImageCarousel( <ImageProvider>[ new NetworkImage('http://www.hilversum.ferraridealers.com/siteasset/ferraridealer/54f07ac8c35b6/961/420/selected/0/0/0/54f07ac8c35b6.jpg'), new NetworkImage('http://auto.ferrari.com/en_EN/wp-content/uploads/sites/5/2017/08/ferrari-portofino-reveal-2017-featured-new.jpg'), new NetworkImage('http://www.hilversum.ferraridealers.com/siteasset/ferraridealer/54f07ac8c35b6/961/420/selected/0/0/0/54f07ac8c35b6.jpg'), ], interval: new Duration(seconds: 1), )
ImageProviderobject instead of custom class
Add this to your package's pubspec.yaml file:
dependencies: image_carousel: ^0.4.1
You can install packages from the command line:
$ pub get
$ flutter packages get
Alternatively, your editor might support
pub get or
flutter packages get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.4.1||Jun 4, 2018|
|0.4.0+1||Mar 7, 2018|
|0.4.0||Jan 3, 2018|
|0.3.0||Dec 22, 2017|
|0.2.0||Oct 15, 2017|
|0.1.3||Oct 13, 2017|
|0.1.2||Oct 13, 2017|
|0.1.1||Oct 13, 2017|
|0.1.0||Oct 13, 2017|
|0.0.1||Oct 13, 2017|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=1.20.0 <2.0.0|