inject 0.2.1

  • README.md
  • Installing
  • Versions
  • 70

This package is reserved.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  inject: ^0.2.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

Version Uploaded Documentation Archive
0.2.1 Nov 30, 2016 Go to the documentation of inject 0.2.1 Download inject 0.2.1 archive
0.2.0 Nov 30, 2016 Go to the documentation of inject 0.2.0 Download inject 0.2.0 archive
0.1.0 Jan 9, 2014 Go to the documentation of inject 0.1.0 Download inject 0.1.0 archive
0.0.1 Jul 4, 2013 Go to the documentation of inject 0.0.1 Download inject 0.0.1 archive
0.0.0 Nov 30, 2016 Go to the documentation of inject 0.0.0 Download inject 0.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
71
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
21
Overall:
Weighted score of the above. [more]
70
Learn more about scoring.

We analyzed this package on Aug 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.11.8

Platforms

Detected platforms: Flutter, web, other

No libraries.

Issues and suggestions

Maintain CHANGELOG.md.

Changelog entries help clients to follow the progress in your code.

Homepage is not helpful.

Update the homepage property: create a website about the package or use the source repository URL.

Add SDK constraint in pubspec.yaml.

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

Package is getting outdated.

The package was released 88 weeks ago.

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v1 release.

While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction of the API.

Maintain an example.

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use inject.dart.