This package is reserved.
Add this to your package's pubspec.yaml file:
dependencies: inject: ^0.2.1
You can install packages from the command line:
$ pub get
$ flutter packages get
Alternatively, your editor might support
pub get or
flutter packages get.
Check the docs for your editor to learn more.
|0.2.1||Nov 30, 2016|
|0.2.0||Nov 30, 2016|
|0.1.0||Jan 9, 2014|
|0.0.1||Jul 4, 2013|
|0.0.0||Nov 30, 2016|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Oct 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Detected platforms: Flutter, web, other
CHANGELOG.md. (-20 points)
Changelog entries help clients to follow the progress in your code.
Homepage is not helpful. (-10 points)
homepage property: create a website about the package or use the source repository URL.
Add SDK constraint in
pubspec.yaml. (-5 points)
For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.
Package is getting outdated. (-85.75 points)
The package was released 96 weeks ago.
The description is too short. (-20 points)
Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package. Common file name patterns include:
example.dart or you could also use