intercom 0.0.5

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 55

intercom_flutter

DEPRECATED This package is deprecated, use intercom_flutter instead.

Flutter wrapper for Intercom Android and iOS projects. Currently only supports registering users and opening Intercom messenger.

Usage

Import package:intercom/intercom.dart and use the methods in Intercom class.

Example:

import 'package:intercom/intercom.dart';

void main() async {
    await Intercom.initialize('appIdHere', iosApiKey: 'iosKeyHere', androidApiKey: 'androidKeyHere');
    runApp(App());
}

class App extends StatelessWidget {

    @override 
    Widget build(BuildContext context) {
        return FlatButton(
            child: Text('Open Intercom'),
            onPressed: () async {
                await Intercom.displayMessenger();
            });
    }
}

See Intercom Android and iOS package documentation for more information.

Android

Permissions:

<uses-permission android:name="android.permission.INTERNET"/>

Optional permissions:

<uses-permission android:name="android.permission.READ_EXTERNAL_STORAGE"/>
<uses-permission android:name="android.permission.MANAGE_DOCUMENTS"/>

iOS

Make sure that you have a NSPhotoLibraryUsageDescription entry in your Info.plist.

0.0.5

  • Deprecated in favour of intercom_flutter package

0.0.4

  • Fixed pod name in podspec

0.0.3

  • Added example project
  • Formatted code
  • Added test

0.0.2

  • Changed minimum SDK version to 2.0.0-dev.28.0

0.0.1

  • Implemented initialize, registerIdentifiedUser, registerUnidentifiedUser, logout, setLauncherVisibility, displayMessenger on both Android and iOS

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:intercom/intercom.dart';

void main() async {
  await Intercom.initialize('appId',
      androidApiKey: 'androidApiKey', iosApiKey: 'iosApiKey');
  runApp(App());
}

class App extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      home: new Scaffold(
        appBar: new AppBar(
          title: const Text('Intercom example app'),
        ),
        body: new Center(
          child: new FlatButton(
              onPressed: () {
                Intercom.displayMessenger();
              },
              child: Text('Show messenger')),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  intercom: ^0.0.5

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:intercom/intercom.dart';
  
Version Uploaded Documentation Archive
0.0.5 Aug 17, 2018 Go to the documentation of intercom 0.0.5 Download intercom 0.0.5 archive
0.0.4 Jul 23, 2018 Go to the documentation of intercom 0.0.4 Download intercom 0.0.4 archive
0.0.3 Jul 23, 2018 Go to the documentation of intercom 0.0.3 Download intercom 0.0.3 archive
0.0.2 Jul 21, 2018 Go to the documentation of intercom 0.0.2 Download intercom 0.0.2 archive
0.0.1 Jul 21, 2018 Go to the documentation of intercom 0.0.1 Download intercom 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
28
Health:
Code health derived from static analysis. [more]
90
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
55
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7
  • Flutter: 1.0.0

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs (-10 points)

12 out of 12 API elements (library, class, field or method) have no adequate dartdoc content. Good documentation improves code readability and discoverability through search.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test
mockito ^2.2.3