intercom_flutter 1.0.10

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 87

intercom_flutter

Pub

Flutter wrapper for Intercom Android and iOS projects. Currently only supports registering users and opening Intercom messenger.

Usage

Import package:intercom_flutter/intercom_flutter.dart and use the methods in Intercom class.

Example:

import 'package:intercom_flutter/intercom_flutter.dart';

void main() async {
    await Intercom.initialize('appIdHere', iosApiKey: 'iosKeyHere', androidApiKey: 'androidKeyHere');
    runApp(App());
}

class App extends StatelessWidget {

    @override 
    Widget build(BuildContext context) {
        return FlatButton(
            child: Text('Open Intercom'),
            onPressed: () async {
                await Intercom.displayMessenger();
            });
    }
}

See Intercom Android and iOS package documentation for more information.

Android

Permissions:

<uses-permission android:name="android.permission.INTERNET"/>

Optional permissions:

<uses-permission android:name="android.permission.READ_EXTERNAL_STORAGE"/>
<uses-permission android:name="android.permission.MANAGE_DOCUMENTS"/>

iOS

Make sure that you have a NSPhotoLibraryUsageDescription entry in your Info.plist.

1.0.10

  • Updated author

1.0.9

  • Added support for companies
  • Added support for custom attributes

1.0.8

  • Fixed issues with nullability in Intercom Android SDK

1.0.7

  • Added Help Center support

1.0.6

  • Fixed null check in ObjectiveC

1.0.5

  • Fixed ObjectiveC warnings

1.0.4

  • Converter Swift code to ObjectiveC

1.0.3

  • Updated iOS project to Swift 4.2

1.0.2

  • Fixed plugin name in all places

1.0.1

  • Fixed ios headers

1.0.0

  • Added user attributes (name, email, phone, userId and company)
  • Renamed package to intercom_flutter because of the name clash with Intercom pod

0.0.4

  • Fixed pod name in podspec

0.0.3

  • Added example project
  • Formatted code
  • Added test

0.0.2

  • Changed minimum SDK version to 2.0.0-dev.28.0

0.0.1

  • Implemented initialize, registerIdentifiedUser, registerUnidentifiedUser, logout, setLauncherVisibility, displayMessenger on both Android and iOS

example/README.md

intercom_example

Demonstrates how to use the intercom plugin.

Getting Started

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  intercom_flutter: ^1.0.10

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:intercom_flutter/intercom_flutter.dart';
  
Version Uploaded Documentation Archive
1.0.10 Nov 22, 2018 Go to the documentation of intercom_flutter 1.0.10 Download intercom_flutter 1.0.10 archive
1.0.9 Nov 22, 2018 Go to the documentation of intercom_flutter 1.0.9 Download intercom_flutter 1.0.9 archive
1.0.8 Oct 12, 2018 Go to the documentation of intercom_flutter 1.0.8 Download intercom_flutter 1.0.8 archive
1.0.7 Sep 4, 2018 Go to the documentation of intercom_flutter 1.0.7 Download intercom_flutter 1.0.7 archive
1.0.6 Aug 21, 2018 Go to the documentation of intercom_flutter 1.0.6 Download intercom_flutter 1.0.6 archive
1.0.5 Aug 21, 2018 Go to the documentation of intercom_flutter 1.0.5 Download intercom_flutter 1.0.5 archive
1.0.4 Aug 21, 2018 Go to the documentation of intercom_flutter 1.0.4 Download intercom_flutter 1.0.4 archive
1.0.3 Aug 17, 2018 Go to the documentation of intercom_flutter 1.0.3 Download intercom_flutter 1.0.3 archive
1.0.2 Aug 17, 2018 Go to the documentation of intercom_flutter 1.0.2 Download intercom_flutter 1.0.2 archive
1.0.1 Aug 17, 2018 Go to the documentation of intercom_flutter 1.0.1 Download intercom_flutter 1.0.1 archive

All 11 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
82
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
87
Learn more about scoring.

We analyzed this package on Jan 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.10
  • Flutter: 1.1.7

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

15 out of 15 API elements (library, class, field or method) have no adequate dartdoc content. Good documentation improves code readability and discoverability through search.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test
mockito ^3.0.0