internet_beats 0.0.2

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 0

internet_beats

A library for Dart developers to generate and manage instances of Internet Time in the form of Internet Beats.

Usage

A simple usage example:

import 'package:internet_beats/internet_beats.dart';

main() {
  InternetBeatsTime theTime = new InternetBeatsTime();

  print("Here, the time is ${theTime.asLocalTime()}");
  print("Everywhere, the time is ${theTime.asInternetBeatsTimeString()} " +
        "or more precisely: ${theTime.preciseInternetBeatsTime()}");
}

Features and bugs

Please e-mail feature requests and bugs to Morgan Sandquist.

Changelog

0.0.1

  • Initial version
  • The 80% of the functionality that takes 20% of the time to develop

0.0.2

  • Updated project URL
  • Switched from MIT to BSD license

example/internet_beats_example.dart

import 'package:internet_beats/internet_beats.dart';

main() {
  InternetBeatsTime theTime = new InternetBeatsTime();

  print("Here, the time is ${theTime.asLocalTime()}");
  print("Everywhere, the time is ${theTime.asInternetBeatsTimeString()} " +
        "or more precisely: ${theTime.preciseInternetBeatsTime()}");
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  internet_beats: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:internet_beats/internet_beats.dart';
  
Version Uploaded Documentation Archive
0.0.2 Apr 5, 2018 Go to the documentation of internet_beats 0.0.2 Download internet_beats 0.0.2 archive
0.0.1 Apr 4, 2018 Go to the documentation of internet_beats 0.0.1 Download internet_beats 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0