intl_helper 0.1.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 25

intl_helper

The intl_helper provides an easy way to use intl_translation package that can generate batch file automatically and scan all the usage of Intl.message() to find out duplicate resources.

Install intl_helper

pub global activate intl_helper

How to use

pub global run intl_helper

Arguments:

  • -a, --arb-output (default: arb)
  • -i, --intl-output (default: lib/intl)

There are two batch files will be generated after command executed: ih_intl_extract and ih_intl_generate.

Generate arb file

After you run the ih_intl_extract batch file, the arb file will be generated (in project/arb directory by default).

Generate messages library

You have to put your arb file path in ih_intl_generate first and then execute that. If you need translate arb, see the session Extracting And Using Translated Messages of Intl package.

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.1.1

  • Fix missing entry point

0.1.0

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  intl_helper: ^0.1.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:intl_helper/msg_item.dart';
import 'package:intl_helper/relative_path_converter.dart';
  
Version Uploaded Documentation Archive
0.1.1 Jun 17, 2017 Go to the documentation of intl_helper 0.1.1 Download intl_helper 0.1.1 archive
0.1.0 Jun 17, 2017 Go to the documentation of intl_helper 0.1.0 Download intl_helper 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
50
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
25
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.23.0 <2.0.0