intl_helper 0.1.1

  • Installing
  • Versions
  • 62


The intl_helper provides an easy way to use intl_translation package that can generate batch file automatically and scan all the usage of Intl.message() to find out duplicate resources.

Install intl_helper

pub global activate intl_helper

How to use

pub global run intl_helper


  • -a, --arb-output (default: arb)
  • -i, --intl-output (default: lib/intl)

There are two batch files will be generated after command executed: ih_intl_extract and ih_intl_generate.

Generate arb file

After you run the ih_intl_extract batch file, the arb file will be generated (in project/arb directory by default).

Generate messages library

You have to put your arb file path in ih_intl_generate first and then execute that. If you need translate arb, see the session Extracting And Using Translated Messages of Intl package.

Features and bugs

Please file feature requests and bugs at the issue tracker.



  • Fix missing entry point


  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  intl_helper: "^0.1.1"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:intl_helper/msg_item.dart';

      import 'package:intl_helper/relative_path_converter.dart';
Version Uploaded Documentation Archive
0.1.1 Jun 17, 2017 Go to the documentation of intl_helper 0.1.1 Download intl_helper 0.1.1 archive
0.1.0 Jun 17, 2017 Go to the documentation of intl_helper 0.1.0 Download intl_helper 0.1.0 archive


We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3


Describes how popular the package is relative to other packages. [more]
34 / 100
Code health derived from static analysis. [more]
85 / 100
Reflects how tidy and up-to-date the package is. [more]
99 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: Flutter, web, other

No platform restriction found in libraries.


  • Package is getting outdated.

    The package was released 52 weeks ago.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use intl_helper.dart.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 2 hints.

    Run dartfmt to format lib/msg_item.dart.

    Run dartfmt to format lib/relative_path_converter.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.23.0 <2.0.0
args ^0.13.7 0.13.7 1.4.3
path ^1.4.1 1.6.1