intl_message 0.1.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 43

intl_message #

Build Status

Parses and formats ICU Message strings.

Usage #

var msg = new IntlMessage("It is now {now, date, long}");

var str = msg.format({
  "now": new DateTime.now()
});

print(str);

msg = new IntlMessage({
  "nl": "Toon is geboren op {now, date, long}",
  "en": "Toon was born on {now, date, long}",
});

IntlMessage.withLocale("nl", () {
  var str = msg.format({
    "birthday": new DateTime(2008,8,16)
  });

  print(str);

});


Features and bugs #

Please file feature requests and bugs at the issue tracker.

Changelog #

0.1.2 #

  • Support Dart 2 in pubspec.yaml

0.1.1 #

  • Dart 2 pre-release compatibility

0.1.0 #

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  intl_message: ^0.1.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:intl_message/intl_message.dart';
  
Version Uploaded Documentation Archive
0.1.2 Aug 16, 2018 Go to the documentation of intl_message 0.1.2 Download intl_message 0.1.2 archive
0.1.1 Jul 18, 2018 Go to the documentation of intl_message 0.1.1 Download intl_message 0.1.1 archive
0.1.0 Apr 1, 2018 Go to the documentation of intl_message 0.1.0 Download intl_message 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
98
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
43
Learn more about scoring.

We analyzed this package on Feb 14, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.13

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:intl_message/intl_message.dart.

Health suggestions

Fix lib/src/formatted.dart. (-1.49 points)

Analysis of lib/src/formatted.dart reported 3 hints:

line 10 col 62: Use = to separate a named parameter from its default value.

line 21 col 54: Use = to separate a named parameter from its default value.

line 39 col 54: Use = to separate a named parameter from its default value.

Fix lib/src/select.dart. (-1 points)

Analysis of lib/src/select.dart reported 2 hints:

line 39 col 18: Use = to separate a named parameter from its default value.

line 60 col 19: Use = to separate a named parameter from its default value.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and intl_message.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <3.0.0
intl ^0.15.2 0.15.7
petitparser >=1.7.6 <3.0.0 2.1.1
Transitive dependencies
path 1.6.2
Dev dependencies
test >=0.12.0 <2.0.0