intl_yaml 0.0.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

intl_yaml

This package able to Auto implement intl globalization method from yaml.

Getting Started

install

  intl_yaml: 0.0.1

usage

  1. install intl
dependencies:
  flutter_localizations:
    sdk: flutter
  1. create globalize yaml

e.g.

assets/i18n/en.yaml

make: 'Make'
stock: 'Stock'
helloUser:
  value: 'hello :user'
  examples:
    user: 'Guest'

assets/i18n/ja.yaml

make: '作る'
stock: 'ストック'
helloUser:
  value: ':user さん、こんにちわ'
  examples:
    user: 'ゲスト'
  1. execute
  --config-file 'select globalize file'
  --config-dir 'select globalize dir(ignore if use `--config-file`)'
  --out-lang-dir 'select dir to output the globalize method';
  --out-service-dir 'select dir to output the globalize service';
  --file-prefix 'globalize method file prefix (defailt: intl_message)';
  --default-locale 'default locale(default: en)';
  --project-name(-p) 'project name(temporary option)';

[0.0.1] - 2018/6/30

  • Initial release.

[0.0.2] - 2018/6/30

  • Update pubspec.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  intl_yaml: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:intl_yaml/parser.dart';
import 'package:intl_yaml/stub.dart';
import 'package:intl_yaml/stub_file.dart';
  
Version Uploaded Documentation Archive
0.0.2 Jun 29, 2018 Go to the documentation of intl_yaml 0.0.2 Download intl_yaml 0.0.2 archive
0.0.1 Jun 29, 2018 Go to the documentation of intl_yaml 0.0.1 Download intl_yaml 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <2.0.0