intl_yaml 0.0.2

  • Installing
  • Versions
  • new41


This package able to Auto implement intl globalization method from yaml.

Getting Started


  intl_yaml: 0.0.1


  1. install intl
    sdk: flutter
  1. create globalize yaml



make: 'Make'
stock: 'Stock'
  value: 'hello :user'
    user: 'Guest'


make: '作る'
stock: 'ストック'
  value: ':user さん、こんにちわ'
    user: 'ゲスト'
  1. execute
  --config-file 'select globalize file'
  --config-dir 'select globalize dir(ignore if use `--config-file`)'
  --out-lang-dir 'select dir to output the globalize method';
  --out-service-dir 'select dir to output the globalize service';
  --file-prefix 'globalize method file prefix (defailt: intl_message)';
  --default-locale 'default locale(default: en)';
  --project-name(-p) 'project name(temporary option)';

[0.0.1] - 2018/6/30

  • Initial release.

[0.0.2] - 2018/6/30

  • Update pubspec.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  intl_yaml: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:intl_yaml/parser.dart';
import 'package:intl_yaml/stub.dart';
import 'package:intl_yaml/stub_file.dart';
Version Uploaded Documentation Archive
0.0.2 Jun 29, 2018 Go to the documentation of intl_yaml 0.0.2 Download intl_yaml 0.0.2 archive
0.0.1 Jun 29, 2018 Go to the documentation of intl_yaml 0.0.1 Download intl_yaml 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jul 21, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0-dev.69.0
  • pana: 0.11.7
  • Flutter: 0.5.5


Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Issues and suggestions

Fix dependencies in pubspec.yaml.

Running flutter packages pub upgrade failed with the following output:

ERR: The current Flutter SDK version is 0.5.5.
 Because intl_yaml requires Flutter SDK version ^0.1.2, version solving failed.

Fix platform conflicts.

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Running dartdoc failed.

Make sure dartdoc runs without any issues.

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v1 release.

While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction of the API.

Maintain an example.

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use intl_yaml.dart.

Format lib/parser.dart.

Run flutter format to format lib/parser.dart.

Format lib/stub.dart.

Run flutter format to format lib/stub.dart.

Format lib/stub_file.dart.

Run flutter format to format lib/stub_file.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <2.0.0