ios_device_check 0.1.2

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 57

ios_device_check

A flutter plugin for iOS DeviceCheck.

Installation

To use this plugin, add ios_device_check as a dependency in your pubspec.yaml file.

Usage

bool isSupported = await IosDeviceCheck.isSupported
String token = await IosDeviceCheck.generateToken()

Note

DeviceCheck API is only supported on iOS 11.0 or newer.

If the plugin is invoked on unsupported platform, it will throw error.

[0.1.2]

  • Formatting.

[0.1.1]

  • Updated README.

[0.1.0]

  • minor release.

example/lib/main.dart

import 'dart:async';

import 'package:flutter/material.dart';
import 'package:flutter/services.dart';

import 'package:ios_device_check/ios_device_check.dart';

void main() => runApp(new MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => new _MyAppState();
}

class _MyAppState extends State<MyApp> {
  String _result = 'Unknown';

  @override
  void initState() {
    super.initState();
    _generateToken();
  }

  Future<void> _generateToken() async {
    String result;

    try {
      result = await IosDeviceCheck.generateToken();
    } on PlatformException catch (e) {
      result = 'Code: ${e.code}\nMessage: ${e.message}\nDetails: ${e.details}';
    }

    if (!mounted) return;

    setState(() {
      _result = result;
    });
  }

  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      home: new Scaffold(
        body: new SingleChildScrollView(
          child: new Text(_result),
        ),
        floatingActionButton: new FloatingActionButton(
          onPressed: _generateToken,
          child: new Icon(Icons.refresh),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  ios_device_check: ^0.1.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:ios_device_check/ios_device_check.dart';
  
Version Uploaded Documentation Archive
0.1.2 Aug 2, 2018 Go to the documentation of ios_device_check 0.1.2 Download ios_device_check 0.1.2 archive
0.1.1 Jul 30, 2018 Go to the documentation of ios_device_check 0.1.1 Download ios_device_check 0.1.1 archive
0.1.0 Jul 16, 2018 Go to the documentation of ios_device_check 0.1.0 Download ios_device_check 0.1.0 archive
0.0.6 Jun 10, 2018 Go to the documentation of ios_device_check 0.0.6 Download ios_device_check 0.0.6 archive
0.0.5 Jun 10, 2018 Go to the documentation of ios_device_check 0.0.5 Download ios_device_check 0.0.5 archive
0.0.4 Jun 10, 2018 Go to the documentation of ios_device_check 0.0.4 Download ios_device_check 0.0.4 archive
0.0.3 Jun 10, 2018 Go to the documentation of ios_device_check 0.0.3 Download ios_device_check 0.0.3 archive
0.0.2 Jun 10, 2018 Go to the documentation of ios_device_check 0.0.2 Download ios_device_check 0.0.2 archive
0.0.1 May 28, 2018 Go to the documentation of ios_device_check 0.0.1 Download ios_device_check 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
14
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
57
Learn more about scoring.

We analyzed this package on Aug 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.11.8
  • Flutter: 0.5.7

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Suggestions

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v1 release.

While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.6 1.14.11
meta 1.1.5 1.1.6
sky_engine 0.0.99
typed_data 1.1.5 1.1.6
vector_math 2.0.6 2.0.8