jaguar_ban_ip 0.1.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 0

jaguar_ban_ip

Interceptors and functions to filter requests based on IP addresses

Usage

A simple usage example:

import 'package:jaguar/jaguar.dart';
import 'package:jaguar_reflect/jaguar_reflect.dart';
import 'package:jaguar_ban_ip/jaguar_ban_ip.dart';

@Api(path: '/api')
class ExampleApi {
  @Get(path: '/info')
  @WrapIPFilter(const IPFilterOptions(const ['127.0.0.0/8'])) //Blocks loopback IPs
  String info() => "A very secret message!";
}

main() async {
  Jaguar server = new Jaguar();
  server.addApi(reflectJaguar(new ExampleApi()));
  await server.serve();
}

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.0.1

  • Initial version, created by Stagehand

example/jaguar_ban_ip_example.dart

// Copyright (c) 2017, SERAGUD. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

import 'package:jaguar/jaguar.dart';
import 'package:jaguar_ban_ip/jaguar_ban_ip.dart';

@Api(path: '/api')
class ExampleApi {
  @Get(path: '/info')
  @WrapOne(#ipFilter)
  String info() => "A very secret message!";

  //Blocks loopback IPs
  IPFilter ipFilter(Context ctx) =>
      new IPFilter(const IPFilterOptions(const ['127.0.0.0/8']).compile());
}

main() async {
  final server = new Jaguar();
  server.addApiReflected(new ExampleApi());
  await server.serve();
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  jaguar_ban_ip: ^0.1.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:jaguar_ban_ip/jaguar_ban_ip.dart';
  
Version Uploaded Documentation Archive
0.1.1 Jul 10, 2017 Go to the documentation of jaguar_ban_ip 0.1.1 Download jaguar_ban_ip 0.1.1 archive
0.1.0 Jun 6, 2017 Go to the documentation of jaguar_ban_ip 0.1.0 Download jaguar_ban_ip 0.1.0 archive
0.0.1 Mar 2, 2017 Go to the documentation of jaguar_ban_ip 0.0.1 Download jaguar_ban_ip 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0