jaguar_cli 2.1.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 42

jaguar_cli

Command line tool for jaguar-dart

Main help

jaguar help

Create new project

begin sub-command creates a new project with the name provided using --name command line option.

jaguar begin --name helloworld

Run the project

cd helloworld
pub get
dart bin/main.dart

Visit http://localhost:10000/hello from your browser.

Clone an example or boilerplate

jaguar create::project --repo boilerplate_mux --name learn_mux

List available example and boilerplates

jaguar list::projects

The complete list is also found at examples repositories as repositories.

Changelog

2.1.2

  • Renamed boilerplate to boilerplate_reflect

2.1.1

  • Removed generators
  • Added begin command

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate jaguar_cli

2. Use it

The package has the following executables:


$ jaguar

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  jaguar_cli: ^2.1.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:jaguar_cli/begin/begin.dart';
import 'package:jaguar_cli/cmd/begin_project.dart';
import 'package:jaguar_cli/cmd/cmd.dart';
import 'package:jaguar_cli/cmd/create_project.dart';
import 'package:jaguar_cli/cmd/list_project_template.dart';
import 'package:jaguar_cli/cmd/version.dart';
import 'package:jaguar_cli/list_projects/list_projects.dart';
import 'package:jaguar_cli/project_creator/using_archive.dart';
import 'package:jaguar_cli/project_creator/using_git_clone.dart';
  
Version Uploaded Documentation Archive
2.1.2 Jul 5, 2018 Go to the documentation of jaguar_cli 2.1.2 Download jaguar_cli 2.1.2 archive
2.1.1 Jul 2, 2018 Go to the documentation of jaguar_cli 2.1.1 Download jaguar_cli 2.1.1 archive
0.0.29 Jul 9, 2017 Go to the documentation of jaguar_cli 0.0.29 Download jaguar_cli 0.0.29 archive
0.0.28 Jul 9, 2017 Go to the documentation of jaguar_cli 0.0.28 Download jaguar_cli 0.0.28 archive
0.0.27 Jul 9, 2017 Go to the documentation of jaguar_cli 0.0.27 Download jaguar_cli 0.0.27 archive
0.0.26 Jul 9, 2017 Go to the documentation of jaguar_cli 0.0.26 Download jaguar_cli 0.0.26 archive
0.0.25 Jun 5, 2017 Go to the documentation of jaguar_cli 0.0.25 Download jaguar_cli 0.0.25 archive
0.0.24 Jun 4, 2017 Go to the documentation of jaguar_cli 0.0.24 Download jaguar_cli 0.0.24 archive
0.0.23 Mar 5, 2017 Go to the documentation of jaguar_cli 0.0.23 Download jaguar_cli 0.0.23 archive
0.0.22 Feb 18, 2017 Go to the documentation of jaguar_cli 0.0.22 Download jaguar_cli 0.0.22 archive

All 31 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
42
Learn more about scoring.

We analyzed this package on Oct 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.4

Platforms

Detected platforms: Flutter, other

Platform components identified in package: io.

Health suggestions

Fix lib/list_projects/list_projects.dart. (-0.50 points)

Analysis of lib/list_projects/list_projects.dart reported 1 hint:

line 3 col 8: Unused import: 'dart:async'.

Maintenance issues and suggestions

Use analysis_options.yaml. (-10 points)

Rename old .analysis_options file to analysis_options.yaml.

Read more about the setup of analysis-options.yaml.

Fix .analysis_options.

We were unable to parse .analysis_options.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use jaguar_cli.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.65.0 <3.0.0
archive ^2.0.0 2.0.4
args ^1.4.3 1.5.0
console ^3.0.0 3.0.0
http ^0.11.3 0.11.3+17 0.12.0
path ^1.6.1 1.6.2
quiver ^0.29.0 0.29.0+2 2.0.0+1
Transitive dependencies
async 2.0.8
charcode 1.1.2
collection 1.14.11
convert 2.0.2
crypto 2.0.6
dart2_constant 1.0.2+dart2
http_parser 3.1.3
matcher 0.12.4
meta 1.1.6
source_span 1.4.1
stack_trace 1.9.3
string_scanner 1.0.4
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
test ^1.2.0