jaguar_file_saver 0.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

Build Status

jaguar_file_saver

File saver interceptor and utilities for Dart

Example

import 'package:jaguar_file_saver/jaguar_file_saver.dart';
import 'dart:io';
import 'package:path/path.dart';

main() async {
  Directory baseDir = await Directory.systemTemp.createTemp('jaguar_file_saver');

  Context ctx = new Context(style: Style.platform);
  String tmpPath = ctx.join(baseDir.path, 'tmp.txt');
  File file = new File(tmpPath);
  await file.writeAsString('hello buddy!');

  FileSaver saver = new FileSaver(baseDir.path);
  String dst = await saver.saveFile(['teja', 'profile'], 'teja.txt', file);

  print(dst);
}

Changelog

0.0.1

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  jaguar_file_saver: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:jaguar_file_saver/jaguar_file_saver.dart';
  
Version Uploaded Documentation Archive
0.0.1 Dec 27, 2016 Go to the documentation of jaguar_file_saver 0.0.1 Download jaguar_file_saver 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0