jaguar_gzip 0.5.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

jaguar_gzip

Gzip compressor interceptors for Jaguar

Usage

A simple usage example:

import 'package:jaguar_gzip/jaguar_gzip.dart';
import 'package:jaguar/jaguar.dart';
import 'package:jaguar_reflect/jaguar_reflect.dart';
import 'package:jaguar_static_file/jaguar_static_file.dart';

@Api(path: '/api')
class ExampleApi {
  @WrapGzipStream()
  @WrapStaticFile()
  @Get(path: '/hello.txt')
  Response<JaguarFile> getHelloTxt() =>
      new Response<JaguarFile>(new JaguarFile('example/data/hello.txt'));
}

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.0.1

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  jaguar_gzip: ^0.5.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:jaguar_gzip/jaguar_gzip.dart';
  
Version Uploaded Documentation Archive
0.5.1 Jul 10, 2017 Go to the documentation of jaguar_gzip 0.5.1 Download jaguar_gzip 0.5.1 archive
0.5.0 Jun 6, 2017 Go to the documentation of jaguar_gzip 0.5.0 Download jaguar_gzip 0.5.0 archive
0.4.0 Feb 19, 2017 Go to the documentation of jaguar_gzip 0.4.0 Download jaguar_gzip 0.4.0 archive
0.0.3 Feb 6, 2017 Go to the documentation of jaguar_gzip 0.0.3 Download jaguar_gzip 0.0.3 archive
0.0.2 Feb 3, 2017 Go to the documentation of jaguar_gzip 0.0.2 Download jaguar_gzip 0.0.2 archive
0.0.1 Feb 3, 2017 Go to the documentation of jaguar_gzip 0.0.1 Download jaguar_gzip 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0