jaguar_martini 0.0.7-dev

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

jaguar_martini

Jekyll and Hugo like static site generator that uses right mix of Markdown, HTML and Dart

Roadmap

High priority

  • [X] Permalink
  • [ ] Sort tags by count
  • [ ] Sort categories by count
  • [ ] Table of content

On the loop

  • [x] Generate single pages
  • [X] Generate lists
  • [X] Generate sections
  • [X] Generate categories
  • [X] Generate tags
  • [ ] List page pagination
  • [ ] Generate home page
  • [ ] Word counts
  • [ ] Reading time calculation
  • [ ] Post summary

In the future

  • [ ] Multiple output formats
  • [ ] Translation
  • [ ] Slide show generation
  • [ ] Generate series

Changelog

0.0.7

  • Home page

0.0.6

  • Page sorting (Untested)

0.0.5

  • Permalinks

0.0.4

  • Experimenting with static file serving

0.0.3

  • List page generation

0.0.2

  • Shortcode parsing

0.0.1

  • Markdown processing
  • Basic writer support

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  jaguar_martini: ^0.0.7-dev

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:jaguar_martini/jaguar_martini.dart';
  
Version Uploaded Documentation Archive
0.0.7-dev Jan 25, 2018 Go to the documentation of jaguar_martini 0.0.7-dev Download jaguar_martini 0.0.7-dev archive
0.0.5-dev Oct 16, 2017 Go to the documentation of jaguar_martini 0.0.5-dev Download jaguar_martini 0.0.5-dev archive
0.0.3-dev Oct 15, 2017 Go to the documentation of jaguar_martini 0.0.3-dev Download jaguar_martini 0.0.3-dev archive
0.0.2-dev Oct 14, 2017 Go to the documentation of jaguar_martini 0.0.2-dev Download jaguar_martini 0.0.2-dev archive
0.0.1-dev Oct 10, 2017 Go to the documentation of jaguar_martini 0.0.1-dev Download jaguar_martini 0.0.1-dev archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0