jaguar_orm_cli 0.2.4

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 2

jaguar_orm_cli

CLI and generator for jaguar_orm

Changelog

0.2.3

  • Angular like table specification

0.2.2

  • Convert camel case fields to snake case

0.0.1

  • Initial version, created by Stagehand

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate jaguar_orm_cli

2. Use it

The package has the following executables:


$ orm

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  jaguar_orm_cli: ^0.2.4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:jaguar_orm_cli/jaguar_orm_cli.dart';
  
Version Uploaded Documentation Archive
0.2.4 Sep 24, 2017 Go to the documentation of jaguar_orm_cli 0.2.4 Download jaguar_orm_cli 0.2.4 archive
0.2.3-dev Sep 24, 2017 Go to the documentation of jaguar_orm_cli 0.2.3-dev Download jaguar_orm_cli 0.2.3-dev archive
0.2.2-dev Sep 24, 2017 Go to the documentation of jaguar_orm_cli 0.2.2-dev Download jaguar_orm_cli 0.2.2-dev archive
0.2.1-dev Sep 24, 2017 Go to the documentation of jaguar_orm_cli 0.2.1-dev Download jaguar_orm_cli 0.2.1-dev archive
0.2.0-dev Sep 24, 2017 Go to the documentation of jaguar_orm_cli 0.2.0-dev Download jaguar_orm_cli 0.2.0-dev archive
Popularity:
Describes how popular the package is relative to other packages. [more]
5
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
2
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0