jaguar_postgresql 0.5.2

  • README.md
  • Installing
  • Versions
  • 39

jaguar_postgresql

A postgresql interceptor for jaguar Edit

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  jaguar_postgresql: "^0.5.2"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:jaguar_postgresql/jaguar_postgresql.dart';
        
Version Uploaded Documentation Archive
0.5.2 Jul 10, 2017 Go to the documentation of jaguar_postgresql 0.5.2 Download jaguar_postgresql 0.5.2 archive
0.5.1 Jun 10, 2017 Go to the documentation of jaguar_postgresql 0.5.1 Download jaguar_postgresql 0.5.1 archive
0.5.0 Jun 7, 2017 Go to the documentation of jaguar_postgresql 0.5.0 Download jaguar_postgresql 0.5.0 archive
0.4.0 Feb 19, 2017 Go to the documentation of jaguar_postgresql 0.4.0 Download jaguar_postgresql 0.4.0 archive
0.3.0 Feb 6, 2017 Go to the documentation of jaguar_postgresql 0.3.0 Download jaguar_postgresql 0.3.0 archive
0.2.0 Jan 21, 2017 Go to the documentation of jaguar_postgresql 0.2.0 Download jaguar_postgresql 0.2.0 archive
0.0.1 Jan 12, 2017 Go to the documentation of jaguar_postgresql 0.0.1 Download jaguar_postgresql 0.0.1 archive

Analysis

This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • tool failures on Feb 14, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
80 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
76 / 100
Overall score:
Weighted score of the above. [more]
39

Platforms

Detected platforms: other

Primary library: package:jaguar_postgresql/jaguar_postgresql.dart with components: io, mirrors.

Suggestions

  • Fix lib/src/interceptor.dart.

    Strong-mode analysis of lib/src/interceptor.dart failed with the following error:

    line: 37 col: 3
    Invalid override. The type of 'PostgresDb.post' ('(Context, Response<dynamic>) → void') isn't a subtype of 'Interceptor<dynamic, dynamic, dynamic>.post' ('(Context, Response<dynamic>) → FutureOr<Response<dynamic>>').

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Fix issues reported by dartanalyzer.

    dartanalyzer reported 1 error(s) and 0 warning(s).

  • Fix .analysis_options.

    We were unable to parse .analysis_options.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use jaguar_postgresql.dart.

  • Use analysis_options.yaml.

    Rename old .analysis_options file to analysis_options.yaml.

  • Enable strong mode analysis.

    Strong mode helps you to detect bugs and potential issues earlier.Start your analysis_options.yaml file with the following:

    analyzer:
      strong-mode: true
    

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <2.0.0
connection_pool >=0.1.2 <0.2.0 0.1.2
jaguar ^0.6.5 0.6.29 1.3.4
postgresql >=0.3.4+1 <0.4.0 0.3.4+1
Transitive dependencies
args 1.2.0 1.3.0
charcode 1.1.1
collection 1.14.5
convert 2.0.1
crypto 2.0.2+1
dice 1.7.0
http_server 0.9.7
intl 0.15.2
logging 0.11.3+1
meta 1.1.2
mime 0.9.6
mustache 0.2.5+1 1.0.0
path 1.5.1
quiver_hashcode 1.0.0
source_span 1.4.0
stack_trace 1.9.2
string_scanner 1.0.2
typed_data 1.1.5
yaml 2.1.13