jaguar_query_sqljocky_data_store 0.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 37

jaguar_query_sqljocky_data_store

Data store implementation for MySQL

Changelog

0.0.1

  • Initial version, created by Stagehand

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  jaguar_query_sqljocky_data_store: "^0.0.1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:jaguar_query_sqljocky_data_store/jaguar_query_sqljocky_data_store.dart';
        
Version Uploaded Documentation Archive
0.0.1 Jul 12, 2017 Go to the documentation of jaguar_query_sqljocky_data_store 0.0.1 Download jaguar_query_sqljocky_data_store 0.0.1 archive

Analysis

This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • tool failures on Feb 17, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
61 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
95 / 100
Overall score:
Weighted score of the above. [more]
37

Platforms

Detected platforms: other

Primary library: package:jaguar_query_sqljocky_data_store/jaguar_query_sqljocky_data_store.dart with components: io, mirrors.

Suggestions

  • Fix lib/src/resource.dart.

    Strong-mode analysis of lib/src/resource.dart failed with the following error:

    line: 24 col: 9
    Undefined class 'DbConnectionInfo'.

  • Fix issues reported by dartanalyzer.

    dartanalyzer reported 1 error(s) and 0 warning(s).

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use jaguar_query_sqljocky_data_store.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0
jaguar ^0.6.5 0.6.11 1.3.4
jaguar_data_store ^0.1.0 0.1.0 0.5.2
jaguar_json ^0.1.2 0.1.3 1.3.1
jaguar_query ^0.2.1 0.2.8
jaguar_query_data_store ^0.2.1 0.2.1
jaguar_query_sqljocky ^0.2.2 0.2.2
jaguar_serializer ^0.3.10 0.3.16 0.5.1
jaguar_sqljocky ^0.1.0 0.1.0
Transitive dependencies
analyzer 0.30.0+4 0.31.1
args 0.13.7 1.3.0
async 1.13.3 2.0.4
barback 0.15.2+14
build 0.9.3 0.12.0+1
build_barback 0.3.0 0.5.0+3
build_runner 0.3.4+1 0.7.11
charcode 1.1.1
cli_util 0.1.2+1
code_transformers 0.5.1+4
collection 1.14.5
convert 2.0.1
crypto 2.0.2+1
csslib 0.14.1
dart_style 1.0.9+1
dice 1.7.0
front_end 0.1.0-alpha.4.1 0.1.0-alpha.10
glob 1.1.5
html 0.13.2+2
http_parser 3.1.1
http_server 0.9.7
intl 0.14.0 0.15.2
isolate 1.1.0
jaguar_generator_config 0.0.1
kernel 0.3.0-alpha.1.1 0.3.0-alpha.10
logging 0.11.3+1
meta 1.1.2
mime 0.9.6
mustache 0.2.5+1 1.0.0
package_config 1.0.3
path 1.5.1
plugin 0.2.0+2
pool 1.3.4
quiver_hashcode 1.0.0
quiver_iterables 1.0.1
shelf 0.6.8 0.7.2
shelf_static 0.2.7
source_gen 0.5.10+1 0.7.5+1
source_gen_help 0.0.4
source_maps 0.10.4
source_span 1.4.0
sqljocky5 1.0.0
stack_trace 1.9.2
stream_channel 1.6.3
stream_transform 0.0.10
string_scanner 1.0.2
teja_http_json 0.1.5 0.1.6-dev
typed_data 1.1.5
utf 0.9.0+4
watcher 0.9.7+7
yaml 2.1.13
yamlicious 0.0.5
Dev dependencies
http ^0.11.3+13 0.11.3+16
test
ulid ^1.0.0