jaguar_recaptcha 1.3.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 1

jaguar_recaptcha

reCAPTCHA server side support Dart and Jaguar.dart

Provides RecaptchaVerifier to verify that the user solved the challenge correctly

Changelog

0.0.1

  • Initial version, created by Stagehand

example/jaguar_recaptcha_example.dart

// Copyright (c) 2017, teja. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

//TODO import 'package:jaguar_recaptcha/jaguar_recaptcha.dart';

main() {
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  jaguar_recaptcha: ^1.3.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:jaguar_recaptcha/jaguar_recaptcha.dart';
  
Version Uploaded Documentation Archive
1.3.1 Feb 2, 2018 Go to the documentation of jaguar_recaptcha 1.3.1 Download jaguar_recaptcha 1.3.1 archive
1.2.1 Jan 14, 2018 Go to the documentation of jaguar_recaptcha 1.2.1 Download jaguar_recaptcha 1.2.1 archive
0.0.4 Jul 18, 2017 Go to the documentation of jaguar_recaptcha 0.0.4 Download jaguar_recaptcha 0.0.4 archive
0.0.3 Jul 16, 2017 Go to the documentation of jaguar_recaptcha 0.0.3 Download jaguar_recaptcha 0.0.3 archive
0.0.1-dev Jul 14, 2017 Go to the documentation of jaguar_recaptcha 0.0.1-dev Download jaguar_recaptcha 0.0.1-dev archive
Popularity:
Describes how popular the package is relative to other packages. [more]
2
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
1
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0