jaguar_session 0.10.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

Jaguar session

Deprecated: This package has been deprecated. Use session infrastructure (Session and SessionManager) provided by Jaguar.

Changelog

0.6.0

  • Introduced createSession
  • Better session management chain with createSession, updateSession and deleteSession
  • Renamed updateResponse to writeResponse

0.0.1

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  jaguar_session: ^0.10.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:jaguar_session/jaguar_session.dart';
  
Version Uploaded Documentation Archive
0.10.0 Nov 4, 2017 Go to the documentation of jaguar_session 0.10.0 Download jaguar_session 0.10.0 archive
0.9.1 Jul 21, 2017 Go to the documentation of jaguar_session 0.9.1 Download jaguar_session 0.9.1 archive
0.9.0 Jul 16, 2017 Go to the documentation of jaguar_session 0.9.0 Download jaguar_session 0.9.0 archive
0.8.1 Jul 9, 2017 Go to the documentation of jaguar_session 0.8.1 Download jaguar_session 0.8.1 archive
0.8.0 Jul 3, 2017 Go to the documentation of jaguar_session 0.8.0 Download jaguar_session 0.8.0 archive
0.7.1 Jun 18, 2017 Go to the documentation of jaguar_session 0.7.1 Download jaguar_session 0.7.1 archive
0.7.0 Jun 18, 2017 Go to the documentation of jaguar_session 0.7.0 Download jaguar_session 0.7.0 archive
0.6.1 Jun 17, 2017 Go to the documentation of jaguar_session 0.6.1 Download jaguar_session 0.6.1 archive
0.6.0 Jun 17, 2017 Go to the documentation of jaguar_session 0.6.0 Download jaguar_session 0.6.0 archive
0.5.4 Jun 5, 2017 Go to the documentation of jaguar_session 0.5.4 Download jaguar_session 0.5.4 archive

All 23 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.22.0 <2.0.0