jaguar_session_mongo 1.3.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 48

jaguar_session_mongo

MongoDb based session manager for Jaguar.dart. Stores session data in a MongoDb collection

Changelog

0.0.1

  • Initial version, created by Stagehand

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  jaguar_session_mongo: "^1.3.1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:jaguar_session_mongo/jaguar_session_mongo.dart';
        
Version Uploaded Documentation Archive
1.3.1 Feb 2, 2018 Go to the documentation of jaguar_session_mongo 1.3.1 Download jaguar_session_mongo 1.3.1 archive
1.2.6 Jan 13, 2018 Go to the documentation of jaguar_session_mongo 1.2.6 Download jaguar_session_mongo 1.2.6 archive
0.0.3 Jul 9, 2017 Go to the documentation of jaguar_session_mongo 0.0.3 Download jaguar_session_mongo 0.0.3 archive
0.0.2 Jul 3, 2017 Go to the documentation of jaguar_session_mongo 0.0.2 Download jaguar_session_mongo 0.0.2 archive
0.0.1 Jun 17, 2017 Go to the documentation of jaguar_session_mongo 0.0.1 Download jaguar_session_mongo 0.0.1 archive

Analysis

We analyzed this package on Apr 9, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.46.0
  • pana: 0.10.6

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
94 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
48
Learn more about scoring.

Platforms

Detected platforms: Flutter, other

Primary library: package:jaguar_session_mongo/jaguar_session_mongo.dart with components: io.

Suggestions

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 8 hints.

    Strong-mode analysis of lib/src/jaguar_session_mongo_base.dart gave the following hint:

    line: 125 col: 18
    'BASE64URL' is deprecated and shouldn't be used.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use jaguar_session_mongo.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0
crypto ^2.0.2 2.0.2+1
jaguar ^1.3.4 1.3.11
jaguar_data_store ^0.5.2 0.5.2
jaguar_mongo ^1.3.1 1.3.1
jaguar_mongo_data_store ^1.3.2 1.3.2
jaguar_serializer ^0.5.1 0.5.1 1.0.0-dev5
mongo_dart ^0.3.0 0.3.1
Transitive dependencies
args 1.4.1
async 2.0.6
bson 0.3.0
charcode 1.1.1
client_cookie 0.1.0
collection 1.14.9
connection_pool 0.1.2
convert 2.0.1
fixnum 0.10.7
http 0.11.3+16
http_parser 3.1.1
http_server 0.9.7
intl 0.15.4
jaguar_client 0.2.1
jaguar_common 0.2.2
logging 0.11.3+1
matcher 0.12.1+4
meta 1.1.2
mime 0.9.6
mongo_dart_query 0.3.0
more 1.9.0
path 1.5.1
pool 1.3.4
quiver_iterables 1.0.1
source_span 1.4.0
stack_trace 1.9.2
string_scanner 1.0.2
typed_data 1.1.5
uuid 0.5.3
yaml 2.1.13
yamlicious 0.0.5
Dev dependencies
auth_header ^0.0.2 0.0.3
jaguar_auth ^1.3.2
jaguar_reflect ^1.3.1
test ^0.12.0