jaguar_settings 2.1.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new50

settings

Settings package for Jaguar.

1.0.0

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  jaguar_settings: "^2.1.1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:jaguar_settings/jaguar_settings.dart';
  
Version Uploaded Documentation Archive
2.1.1 Jun 7, 2018 Go to the documentation of jaguar_settings 2.1.1 Download jaguar_settings 2.1.1 archive

Analysis

We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
99 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
50
Learn more about scoring.

Platforms

Detected platforms: Flutter, other

Primary library: package:jaguar_settings/jaguar_settings.dart with components: io.

Suggestions

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use jaguar_settings.dart.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 1 hint.

    Run dartfmt to format lib/jaguar_settings.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.55.0 <2.0.0
args >=0.13.7 <2.0.0 1.4.3
yaml ^2.1.14 2.1.14
Transitive dependencies
charcode 1.1.1
collection 1.14.10
path 1.6.1
source_span 1.4.0
string_scanner 1.0.2
Dev dependencies
test ^0.12.30