jaguar_shelf 0.1.1

  • Installing
  • Versions
  • 0


Shelf integration for Jaguar. Use shelf handlers and middleware in Jaguar


A simple usage example:

import 'package:jaguar_shelf/jaguar_shelf.dart';
import 'package:shelf/shelf.dart' as shelf;
import 'package:jaguar/jaguar.dart';

main() async {
  shelf.Response echoHandler(shelf.Request request) =>
      new shelf.Response.ok("You've requested ${request.url}");
  final shelfHandler = new ShelfHandler(echoHandler);

  Configuration conf = new Configuration();
  await serve(conf);

Features and bugs

Please file feature requests and bugs at the issue tracker.



  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  jaguar_shelf: ^0.1.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:jaguar_shelf/jaguar_shelf.dart';
Version Uploaded Documentation Archive
0.1.1 Jul 10, 2017 Go to the documentation of jaguar_shelf 0.1.1 Download jaguar_shelf 0.1.1 archive
0.1.0 Jun 7, 2017 Go to the documentation of jaguar_shelf 0.1.0 Download jaguar_shelf 0.1.0 archive
0.0.2 Feb 19, 2017 Go to the documentation of jaguar_shelf 0.0.2 Download jaguar_shelf 0.0.2 archive
0.0.1 Feb 12, 2017 Go to the documentation of jaguar_shelf 0.0.1 Download jaguar_shelf 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0