jaguar_sqljocky 2.4.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 48

jaguar_sqljocky #

MySQL interceptor for jaguar

Changelog #

0.0.1 #

  • Initial version, created by Stagehand

example/jaguar_sqljocky_example.dart

// Copyright (c) 2017, teja. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

// import 'package:jaguar_sqljocky/jaguar_sqljocky.dart';

main() {}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  jaguar_sqljocky: ^2.4.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:jaguar_sqljocky/jaguar_sqljocky.dart';
  
Version Uploaded Documentation Archive
2.4.1 Sep 18, 2018 Go to the documentation of jaguar_sqljocky 2.4.1 Download jaguar_sqljocky 2.4.1 archive
0.1.0 Jul 12, 2017 Go to the documentation of jaguar_sqljocky 0.1.0 Download jaguar_sqljocky 0.1.0 archive
0.0.1 Jul 12, 2017 Go to the documentation of jaguar_sqljocky 0.0.1 Download jaguar_sqljocky 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
22
Health:
Code health derived from static analysis. [more]
70
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

We analyzed this package on Apr 25, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14

Platforms

Detected platforms: Flutter, other

Primary library: package:jaguar_sqljocky/jaguar_sqljocky.dart with components: io.

Health issues and suggestions

Fix lib/src/manager.dart. (-26.86 points)

Analysis of lib/src/manager.dart failed with 1 error, 5 hints, including:

line 34 col 3: The final variable 'timeZone' must be initialized.

line 36 col 14: Use = to separate a named parameter from its default value.

line 37 col 14: Use = to separate a named parameter from its default value.

line 38 col 18: Use = to separate a named parameter from its default value.

line 40 col 16: Use = to separate a named parameter from its default value.

Fix lib/src/interceptor.dart. (-3.93 points)

Analysis of lib/src/interceptor.dart reported 8 hints, including:

line 16 col 19: Use = to separate a named parameter from its default value.

line 17 col 15: Use = to separate a named parameter from its default value.

line 18 col 22: Use = to separate a named parameter from its default value.

line 20 col 18: Use = to separate a named parameter from its default value.

line 21 col 27: Use = to separate a named parameter from its default value.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
conn_pool ^2.1.8 2.1.9
jaguar ^2.4.4 2.4.36
sqljocky5 ^2.2.0 2.2.1
Transitive dependencies
auth_header 2.1.2
charcode 1.1.2
collection 1.14.11
convert 2.1.1
crypto 2.0.6
http_server 0.9.8+1
jaguar_common 2.1.4
jaguar_serializer 2.2.12
logging 0.11.3+2
meta 1.1.7
mime 0.9.6+2
path 1.6.2
path_tree 2.2.2
stack_trace 1.9.3
synchronized 1.5.3+2 2.1.0
typed_buffer 2.1.1
typed_data 1.1.6
Dev dependencies
jaguar_reflect ^2.4.0