jalaali 0.3.0

  • README.md
  • Example
  • Installing
  • Versions
  • new67

Jalaali plugin for Flutter pub package

A flutter package to make working with solar date easier. You can convert dates to solar dates and manipulate those by using this package in your app.


First add jalaali as a dependency in your pubspec.yaml file.

[0.3.0] - 30th October 2018

[0.2.0] - 29th October 2018

  • Changed the algorithm for convertion
  • Removed extra constructors
  • Added toDateTime method. see documents

[0.1.0] - 28th October 2018

  • Under Developement
  • Added some docs


import 'package:jalaali/jalaali.dart';

void main() {
  JalaaliDate currentDate = JalaaliDate.now();
  print("Current Date is: " + currentDate.toString());

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  jalaali: ^0.3.0

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:jalaali/jalaali.dart';
Version Uploaded Documentation Archive
0.3.0 Oct 30, 2018 Go to the documentation of jalaali 0.3.0 Download jalaali 0.3.0 archive
0.2.0 Oct 29, 2018 Go to the documentation of jalaali 0.2.0 Download jalaali 0.2.0 archive
0.1.0 Oct 28, 2018 Go to the documentation of jalaali 0.1.0 Download jalaali 0.1.0 archive
0.0.2 Oct 28, 2018 Go to the documentation of jalaali 0.0.2 Download jalaali 0.0.2 archive
0.0.1 Oct 28, 2018 Go to the documentation of jalaali 0.0.1 Download jalaali 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Nov 14, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.6
  • Flutter: 0.11.3


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies