jb_option_input 4.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

jb_option_input

An AngularDart 1 Component for being re-used in other AngularDart projects

Usage

  1. Add the component to your pubspec.yaml (see 'Install' tab)
  1. Show your component to angular dependency injection -> see App Class in app_initialize.dart

     import 'package:jb_option_input/jb_option_input.dart';
    
     class App extends Angular.Module {
    
       App() {
         bind(JbOptionInput);
       }
     }
    

Changelog

4.0.1

  • some cleaning for publishing

4.0.0

  • updates to Angular 4

2.0.0

  • updated to Angular 2

1.1.2

  • hide label for select mode if empty

1.1.1

  • changed p tag for radio group label to span

1.1.0

  • Added label attribute
  • Shortened current-value attribute to value
  • Added display-style attribute
  • Added mode to display this component as dom.SelectElement
  • added random double number as name seed to option buttons name attributes to separate the options from one jb-option-input from another on the same page

1.0.0

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  jb_option_input: ^4.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:jb_option_input/jb_option_input.dart';
  
Version Uploaded Documentation Archive
4.0.1 Jan 18, 2018 Go to the documentation of jb_option_input 4.0.1 Download jb_option_input 4.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.0 <2.0.0