jmessage_flutter 0.0.3

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new41

QQ Group

jmessage_flutter

安装

在工程 pubspec.yaml 中加入 dependencies

dependencies:
  jmessage_flutter: 0.0.2

配置

/android/app/build.gradle 中添加下列代码:

android {
    ......
    defaultConfig {
        applicationId "com.xxx.xxx" //JPush上注册的包名.
        ......

        ndk {
            //选择要添加的对应cpu类型的.so库。
            abiFilters 'armeabi', 'armeabi-v7a', 'armeabi-v8a'
            // 还可以添加 'x86', 'x86_64', 'mips', 'mips64'
        }

        manifestPlaceholders = [
            JPUSH_PKGNAME : applicationId,
            JPUSH_APPKEY : "你的appkey", //JPush上注册的包名对应的appkey.
            JPUSH_CHANNEL : "developer-default", //暂时填写默认值即可.
        ]
        ......
    }
    ......
}

使用

import 'package:jmessage_flutter/jmessage_flutter.dart';

APIs

注意 : 需要先调用 JmessageFlutter().init 来初始化插件,才能保证其它功能正常工作。

参考

0.0.3

fix: android isSend 返回错误。

0.0.2

fix: swift 工程集成报错。

0.0.1

第一个版本。

example/README.md

jmessage_flutter_example

Demonstrates how to use the jmessage_flutter plugin.

Getting Started

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  jmessage_flutter: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:jmessage_flutter/jmessage_flutter.dart';
  
Version Uploaded Documentation Archive
0.0.3 Jan 15, 2019 Go to the documentation of jmessage_flutter 0.0.3 Download jmessage_flutter 0.0.3 archive
0.0.2 Jan 13, 2019 Go to the documentation of jmessage_flutter 0.0.2 Download jmessage_flutter 0.0.2 archive
0.0.1 Jan 11, 2019 Go to the documentation of jmessage_flutter 0.0.1 Download jmessage_flutter 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
91
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
41
Learn more about scoring.

We analyzed this package on Jan 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.10
  • Flutter: 1.1.7

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Fix lib/jmessage_flutter.dart. (-8.73 points)

Analysis of lib/jmessage_flutter.dart reported 1 warning, 8 hints, including:

line 2047 col 41: The parameter 'type' is required.

line 1096 col 36: Avoid using braces in interpolation when not needed.

line 1243 col 18: Equality operator == invocation with references of unrelated types.

line 1244 col 27: Equality operator == invocation with references of unrelated types.

line 1302 col 17: Always override hashCode if overriding ==.

Document public APIs. (-0.50 points)

468 out of 476 API elements (library, class, field or method) have no adequate dartdoc content. Good documentation improves code readability and discoverability through search.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
platform ^2.0.0 2.2.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test
mockito ^3.0.0
test ^1.3.0