js 0.3.0

This package is deprecated in favor of dart:js.

If you are using package:js (the old version of this package), we recommend that you port your code over to dart:js.

Usage of package:js version <= 0.2.2 can greatly increase the size of your generated JavaScript.

We are working on a next-generation package:js, but if you need to interop with JavaScript now, please use dart:js.

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  js: ">=0.3.0 <0.4.0"

If your package is an application package you should use any as the version constraint.

2. Install it

You can install packages from the command line:

$ pub get

Alternatively, your editor might support pub. Check the docs for your editor to learn more.

About

Deprecated. Please use dart:js.

Author

Email misc@dartlang.org Dart Team

Homepage

github.com/dart-lang/js-interop

Documentation

www.dartdocs.org/documentation/js/0.3.0/index.html#js

Uploader

vsm@google.com
jmesserly@google.com
efortuna@google.com
sigmund@google.com
justinfagnani@google.com
alexandre.ardhuin@gmail.com
sethladd@google.com

Share