json2dart 1.0.2

  • README.md
  • Installing
  • Versions
  • 0

json2dart

Generates Dart classes from JSON.

Installation

pub global activate json2dart

Usage

From the command-line:

json2dart foo.json >> foo.dart
json2dart --owl bar.json >> bar.dart # Generate `package:owl_codegen` metadata as well
json2dart -c ArbitraryClassName baz.json >> arbitrary.dart

This package also supports a package:build builder in package:json2dart/builder.dart.

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate json2dart

2. Use it

The package has the following executables:


$ json2dart

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  json2dart: ^1.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:json2dart/json2dart.dart';
  
Version Uploaded Documentation Archive
1.0.2 Mar 11, 2017 Go to the documentation of json2dart 1.0.2 Download json2dart 1.0.2 archive
1.0.1 Mar 11, 2017 Go to the documentation of json2dart 1.0.1 Download json2dart 1.0.1 archive
1.0.0 Mar 6, 2017 Go to the documentation of json2dart 1.0.0 Download json2dart 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.0.0.
 
 Because json2dart depends on inflection >=0.2.0 which requires SDK version <2.0.0, version solving failed.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

Homepage does not exists. (-20 points)

We were unable to access https://thosakwe.github.io/json2dart at the time of the analysis.

Package is getting outdated. (-61.10 points)

The package was released 84 weeks ago.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example.

None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use json2dart.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0