json_validator 0.5.1

  • README.md
  • Installing
  • Versions
  • 0


A library for Dart developers. Its purpose is to validate json data structures. The data structure is modelled using Validator objects. Then the json data structure can be validated. Missing fields are identified and can optionally be replaced with a default value. Fields of the wrong type are identified and removed from the validated object.


A simple usage example:

import 'package:json_validator/type_validator.dart';

main() {
  var personMap = {"name":"sarah", "age":40, "hasLongHair":false};

  var personValidator = new MapValidator({
    "age":new MapField(INT),
    "name":new MapField(STRING),
    "hasLongHair":new MapField(BOOL, defaultValue:false),
    "likesIceCream":new MapField(BOOL, defaultValue:true),


Please see the test file for more usage examples.


A library to check cross-dependencies in json maps. Classes and methods in this library can verify that keys or values at one location in a map are also present at other locations. Consider a map containing a list of orders and and list of products. the orders contain productIds. These can be checked to see if they are present in the product list.


A simple usage example:

import 'package:json_validator/dependencies.dart';

var map = {
  "orders": {
    "order0001": {
      "products": {
        "product001": {
          "amount": 3,
          "options": {
  "products": {
    "product001": {
      "options": {
        "option001": {

main() {
  var sourceTemplate = new SourceTemplate(["orders", "*", "products", "*", "options", "*"], true);
  var locationTemplate = new LocationTemplate(["products", "#1", "options", "#2", "VAL"], null);

  var sourceList = new SourceList.fromMapAndSourceTemplate(map, sourceTemplate);
  var locationList = new LocationList.fromSourceListAndTemplate(sourceList, locationTemplate);

  var verifiedLocationList = locationList.validateWithMap(map);

Features and bugs

Please file feature requests and bugs at the issue tracker.



  • Initial version, created by Stagehand


  • Changed syntax to allow simpler composition


  • Changed validation of simple types to static instances. Added object validation framework


  • Updated documentation


  • bug fix


  • implemented finer grained control of validation of map fields


  • moved all logic that effects map fields to the map field constructor


  • changed object builder argument to dynamic to allow building of objects from simple values

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  json_validator: ^0.5.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:json_validator/dependencies.dart';
import 'package:json_validator/type_validator.dart';
Version Uploaded Documentation Archive
0.5.1 Oct 22, 2017 Go to the documentation of json_validator 0.5.1 Download json_validator 0.5.1 archive
0.5.0 Oct 19, 2017 Go to the documentation of json_validator 0.5.0 Download json_validator 0.5.0 archive
0.4.0 Oct 17, 2017 Go to the documentation of json_validator 0.4.0 Download json_validator 0.4.0 archive
0.3.0 Oct 15, 2017 Go to the documentation of json_validator 0.3.0 Download json_validator 0.3.0 archive
0.2.2 Oct 14, 2017 Go to the documentation of json_validator 0.2.2 Download json_validator 0.2.2 archive
0.2.1 Oct 14, 2017 Go to the documentation of json_validator 0.2.1 Download json_validator 0.2.1 archive
0.2.0 Oct 14, 2017 Go to the documentation of json_validator 0.2.0 Download json_validator 0.2.0 archive
0.1.0 Oct 13, 2017 Go to the documentation of json_validator 0.1.0 Download json_validator 0.1.0 archive
0.0.1 Oct 12, 2017 Go to the documentation of json_validator 0.0.1 Download json_validator 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0