jsonpadding 0.1.0

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 29

jsonpadding

A jsonp library for Dart.

Usage

A simple usage example:

import 'package:jsonpadding/jsonpadding.dart';

main() {

  /// uri could also be a [String]
  Uri uri = new Uri(
      scheme: 'http',
      host: 'en.wikipedia.org',
      path: 'w/api.php',
      queryParameters: {
        'search': 'brazil',
        'action': 'opensearch',
        'format': 'json'
      }
  );

  jsonp(uri).then(print);

  /// Also available as a class
  new Jsonp()..get(uri).then(print);
}

Changelog

0.0.1

  • Initial version, created by Stagehand

example/main.dart

import 'package:jsonpadding/jsonpadding.dart';

main() {
  /// uri could also be an [String]
  Uri uri = new Uri(
      scheme: 'http',
      host: 'en.wikipedia.org',
      path: 'w/api.php',
      queryParameters: {
        'search': 'brazil',
        'action': 'opensearch',
        'format': 'json'
      });

  jsonp(uri).then(print, onError: print);

  /// Also available as a class
  new Jsonp()..get(uri).then(print, onError: print);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  jsonpadding: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:jsonpadding/jsonpadding.dart';
  
Version Uploaded Documentation Archive
1.0.2 Aug 6, 2018 Go to the documentation of jsonpadding 1.0.2 Download jsonpadding 1.0.2 archive
1.0.1 May 8, 2018 Go to the documentation of jsonpadding 1.0.1 Download jsonpadding 1.0.1 archive
1.0.0 May 8, 2018 Go to the documentation of jsonpadding 1.0.0 Download jsonpadding 1.0.0 archive
0.1.0 Feb 10, 2016 Go to the documentation of jsonpadding 0.1.0 Download jsonpadding 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
57
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
29
Learn more about scoring.

This package version is not analyzed, because it is more than two years old. Check the latest stable version for its analysis.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0