jsproxy 1.0.0

  • README.md
  • Installing
  • Versions
  • 66


Creates a JavaScript interface for a dart project so that a dart library can be easily used from JavaScript world.

[Experimental] It is at a very early stage today. The user needs to specify a conversion function to expose dart library (Please see test.dart as an example). The goal of this project is to provide an annotation and an transformer which auto generate a javascript interface for a dart library.


  • Fix function conversion


  • In createJsProxy function, it the obj is not coverred by any case, return a JsProxy.


  • Fix stack overflow


  • pass customConversionFunc into futureProxy


  • Add isFuture in FutureProxy


  • Initial implementation

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  jsproxy: "^1.0.0"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:jsproxy/jsproxy.dart';
Version Uploaded Documentation Archive
1.0.0 Mar 2, 2018 Go to the documentation of jsproxy 1.0.0 Download jsproxy 1.0.0 archive
0.0.6 May 3, 2016 Go to the documentation of jsproxy 0.0.6 Download jsproxy 0.0.6 archive
0.0.5 Aug 19, 2015 Go to the documentation of jsproxy 0.0.5 Download jsproxy 0.0.5 archive
0.0.4 Jul 25, 2015 Go to the documentation of jsproxy 0.0.4 Download jsproxy 0.0.4 archive
0.0.3 Jul 19, 2015 Go to the documentation of jsproxy 0.0.3 Download jsproxy 0.0.3 archive
0.0.2 Jul 10, 2015 Go to the documentation of jsproxy 0.0.2 Download jsproxy 0.0.2 archive
0.0.1 Jun 14, 2015 Go to the documentation of jsproxy 0.0.1 Download jsproxy 0.0.1 archive


We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3


Describes how popular the package is relative to other packages. [more]
35 / 100
Code health derived from static analysis. [more]
95 / 100
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: web

Primary library: package:jsproxy/jsproxy.dart with components: html, js.


  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use jsproxy.dart.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 4 hints.

    Strong-mode analysis of lib/jsproxy.dart gave the following hint:

    line: 3 col: 8
    Unused import: 'src/js_future_proxy.dart'.

    Run dartfmt to format lib/src/js_future_proxy.dart.

    Similar analysis of the following files failed:

    • lib/src/js_object_proxy.dart (hint)


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.1
Dev dependencies
test any