just_google_signin 0.1.0

  • README.md
  • Installing
  • Versions
  • 0

Just Google SignIn #

A simple Google SignIn library for Dart with support for an OpenID Connect.

Usage #

import 'dart:async';
import 'package:just_google_signin/just_google_signin.dart';

main() async {
  var params = new InitParams('<CLIENT_ID>', scope: 'email');
  var auth = await init(params);
  if (!auth.isSignedIn) {
    // Show a Google SignIn form.
    await auth.signIn();
  var user = auth.user;
  print('User name: ${user.profile.name}');
  print('JWT token: ${user.tokens.idToken}');

Background #

Changelog #

0.1.0 #

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  just_google_signin: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:just_google_signin/just_google_signin.dart';
Version Uploaded Documentation Archive
0.1.0 Oct 29, 2016 Go to the documentation of just_google_signin 0.1.0 Download just_google_signin 0.1.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.16.0 <2.0.0