katex_js 0.1.0+1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 7

A Dart API wrapper for KaTeX.js, a library for Fast math typesetting for the web.

Pub

Note that there is also an alternative Dart port of KaTeX.

0.1.0

  • Initial release.

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  katex_js: "^0.1.0+1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:katex_js/katex_js.dart';
        
Version Uploaded Documentation Archive
0.1.0+1 Apr 7, 2016 Go to the documentation of katex_js 0.1.0+1 Download katex_js 0.1.0+1 archive
0.1.0 Apr 7, 2016 Go to the documentation of katex_js 0.1.0 Download katex_js 0.1.0 archive

Analysis

This feature is new.
We welcome feedback.

We analyzed this package, and provided a score, details, and suggestions below.

  • tool failures on Dec 6, 2017
  • Dart: 2.0.0-dev.8.0
  • pana: 0.7.3+1

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
9
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
21
Overall score:
Weighted score of the above. [more]
7

Platforms

Detected platforms:

Error(s) in lib/katex_js.dart: Undefined class 'Element'.

Suggestions

  • Fix lib/katex_js.dart.

    Strong-mode analysis of lib/katex_js.dart failed with the following error:

    line: 12 col: 41
    Undefined class 'Element'.

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

Dependencies

Package Constraint Resolved Available
Direct dependencies
browser ^0.10.0+2 0.10.0+2
js ^0.6.0 0.6.1