Dart Kernel is a small high-level language derived from Dart. It is designed for use as an intermediate format for whole-program analysis and transformations, and as a frontend for codegen and execution backends.
The kernel language has in-memory representations in Dart and C++, and can be serialized as binary or text.
Both the kernel language and its implementations are unstable and are under development.
This package contains the Dart part of the implementation and contains:
Note: The APIs in this package are in an early state; developers should be careful about depending on this package.
Checkout the repository and run pub get:
git clone https://github.com/dart-lang/kernel cd kernel pub get
tool/dartk.dart from the command-line to convert between .dart files
and the serialized binary and textual formats.
dartk expects the
.dill extension for files in the binary format.
The textual format has no preferred extension right now.
dartk foo.dart # print text IR for foo.dart dartk foo.dart -ofoo.dill # write binary IR for foo.dart to foo.dill dartk foo.dill # print text IR for binary file foo.dill
-l flag to link all transitive dependencies into one file:
dartk myapp.dart -ppackages -l -omyapp.dill # Bundle everything. dartk myapp.dill # Print it back out in a (very, very long) textual format.
If you plan to make changes to kernel, get a checkout of the Dartk SDK and run:
tool/regenerate_dill_files.dart --sdk <path to SDK checkout> pub run test
Linking from binary files is not yet implemented. In order to compile a whole program, currently everything must be compiled from source at once.
Add this to your package's pubspec.yaml file:
dependencies: kernel: ^0.3.0-alpha.11
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.3.7||Nov 29, 2018|
|0.3.6+9||Dec 11, 2018|
|0.3.6+8||Nov 29, 2018|
|0.3.6+7||Nov 28, 2018|
|0.3.6+6||Nov 21, 2018|
|0.3.6+5||Nov 14, 2018|
|0.3.6+4||Nov 14, 2018|
|0.3.6+3||Nov 6, 2018|
|0.3.6+2||Nov 2, 2018|
|0.3.6+1||Oct 25, 2018|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
dartdoc failed. (-10 points)
dartdoc runs without any issues.
|Dart SDK||>=1.8.0 <2.0.0|