kernel 0.3.2

  • README.md
  • Installing
  • Versions
  • 48

Dart Kernel

Dart Kernel is a small high-level language derived from Dart. It is designed for use as an intermediate format for whole-program analysis and transformations, and as a frontend for codegen and execution backends.

The kernel language has in-memory representations in Dart and C++, and can be serialized as binary or text.

Both the kernel language and its implementations are unstable and are under development.

This package contains the Dart part of the implementation and contains:

  • A transformable IR for the kernel language
  • A frontend based on the analyzer
  • Serialization of kernel code

Note: The APIs in this package are in an early state; developers should be careful about depending on this package. In particular, there is no semver contract for release versions of this package. Please depend directly on individual versions.

Getting Kernel

Checkout the repository and run pub get:

git clone https://github.com/dart-lang/kernel
cd kernel
pub get

Command-Line Tool

Run tool/dartk.dart from the command-line to convert between .dart files and the serialized binary and textual formats.

dartk expects the .dill extension for files in the binary format. The textual format has no preferred extension right now.

Example commands:

dartk foo.dart            # print text IR for foo.dart
dartk foo.dart -ofoo.dill # write binary IR for foo.dart to foo.dill
dartk foo.dill            # print text IR for binary file foo.dill

Pass the --link or -l flag to link all transitive dependencies into one file:

dartk myapp.dart -ppackages -l -omyapp.dill # Bundle everything.
dartk myapp.dill # Print it back out in a (very, very long) textual format.

See ast.dart for the in-memory IR, or binary.md for a description of the binary format. For now, the textual format is very ad-hoc and cannot be parsed back in.

Testing

If you plan to make changes to kernel, get a checkout of the Dartk SDK and run:

tool/regenerate_dill_files.dart --sdk <path to SDK checkout>
pub run test

Linking

Linking from binary files is not yet implemented. In order to compile a whole program, currently everything must be compiled from source at once.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  kernel: ^0.3.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:kernel/kernel.dart';
  
Version Uploaded Documentation Archive
0.3.6 Oct 4, 2018 Go to the documentation of kernel 0.3.6 Download kernel 0.3.6 archive
0.3.5 Sep 12, 2018 Go to the documentation of kernel 0.3.5 Download kernel 0.3.5 archive
0.3.4+2 Oct 4, 2018 Go to the documentation of kernel 0.3.4+2 Download kernel 0.3.4+2 archive
0.3.4+1 Aug 31, 2018 Go to the documentation of kernel 0.3.4+1 Download kernel 0.3.4+1 archive
0.3.4 Jul 20, 2018 Go to the documentation of kernel 0.3.4 Download kernel 0.3.4 archive
0.3.3 Jul 4, 2018 Go to the documentation of kernel 0.3.3 Download kernel 0.3.3 archive
0.3.2 Jun 26, 2018 Go to the documentation of kernel 0.3.2 Download kernel 0.3.2 archive
0.3.1 May 30, 2018 Go to the documentation of kernel 0.3.1 Download kernel 0.3.1 archive
0.3.0 May 14, 2018 Go to the documentation of kernel 0.3.0 Download kernel 0.3.0 archive
0.2.0 Apr 21, 2017 Go to the documentation of kernel 0.2.0 Download kernel 0.2.0 archive

All 21 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
96
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.48.0 <2.0.0