key_value_store_web 1.0.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new76

key_value_store_web

Web implementation of key_value_store for Multiplatform Dart projects.

For more documentation, see: https://github.com/roughike/multiplatform_key_value_store

1.0.0

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  key_value_store_web: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:key_value_store_web/key_value_store_web.dart';
  
Version Uploaded Documentation Archive
1.0.0 Nov 4, 2018 Go to the documentation of key_value_store_web 1.0.0 Download key_value_store_web 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
65
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
76
Learn more about scoring.

We analyzed this package on Nov 14, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.6

Platforms

Detected platforms: web

Primary library: package:key_value_store_web/key_value_store_web.dart with components: html.

Health suggestions

Format lib/key_value_store_web.dart.

Run dartfmt to format lib/key_value_store_web.dart.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use key_value_store_web.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
key_value_store ^1.0.0 1.0.0
Dev dependencies
build_runner ^0.9.0
build_test ^0.10.2
build_web_compilers ^0.4.1
mockito ^3.0.0
test ^1.0.0