kilobyte 0.1.0+2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 33

kilobyte

pub package Build Status Coverage Status

Cross-platform human-readable file size.

Warning: This is not an official Google or Dart project.

Installation

dependencies:
  kilobyte: ^0.1.0

Usage

Use the Size class similar to how you would the Duration class from the core libraries:

final size = new Size(gigabyte: 1, megabytes: 500);
print(size); // 1.50 Gb

0.1.0+2

  • Increase test coverage, fix badges for build/coverage.

0.1.0+1

  • Update README.md.
  • Added a @literal annotation to the constructor.

0.1.0

  • Initial commit.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  kilobyte: ^0.1.0+2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:kilobyte/kilobyte.dart';
  
Version Uploaded Documentation Archive
0.1.0+2 May 27, 2017 Go to the documentation of kilobyte 0.1.0+2 Download kilobyte 0.1.0+2 archive
0.1.0+1 May 27, 2017 Go to the documentation of kilobyte 0.1.0+1 Download kilobyte 0.1.0+1 archive
0.1.0 May 27, 2017 Go to the documentation of kilobyte 0.1.0 Download kilobyte 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
66
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
33
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.22.0 <2.0.0