kod 1.0.4

  • README.md
  • Installing
  • Versions
  • new13

kod.tehnolab.org

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  kod: "^1.0.4"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:kod/kod.dart';
  
Version Uploaded Documentation Archive
1.0.4 May 16, 2018 Go to the documentation of kod 1.0.4 Download kod 1.0.4 archive
1.0.3 May 16, 2018 Go to the documentation of kod 1.0.3 Download kod 1.0.3 archive
1.0.2 May 16, 2018 Go to the documentation of kod 1.0.2 Download kod 1.0.2 archive
1.0.1 May 16, 2018 Go to the documentation of kod 1.0.1 Download kod 1.0.1 archive
1.0.0 May 16, 2018 Go to the documentation of kod 1.0.0 Download kod 1.0.0 archive
0.0.1 May 15, 2018 Go to the documentation of kod 0.0.1 Download kod 0.0.1 archive

Analysis

We analyzed this package on May 20, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0-dev.54.0
  • pana: 0.10.6

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
11 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
47 / 100
Overall score:
Weighted score of the above. [more]
13
Learn more about scoring.

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Make sure dartfmt runs.

Suggestions

  • Make sure dartfmt runs.

    Running dartfmt -n . failed with the following output:

    dartfmt on lib/ failed with exit code 65
    Could not format because the source could not be parsed:
    
    line 9, column 29 of /tmp/pana-FXGTMQ/lib/src/kod_base.dart: Expected to find ';'.
    final Env replEnv = new Env()
                                ^
    
  • Fix platform conflicts.

    Error(s) prevent platform classification:

    Make sure dartfmt runs.

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 34 errors 5 hints.

    Strong-mode analysis of lib/src/kod_base.dart failed with the following error:

    line: 49 col: 20
    Undefined class 'MalType'.

    Run dartfmt to format lib/kod.dart.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0
Dev dependencies
test ^0.12.0