landgrab 0.0.1

  • README.md
  • Installing
  • Versions
  • 42

Go Report Card

landgrab

landgrab is a board game and AI platform with multiple interfaces for playing.

Provided interfaces are a CLI app, a web app, and mobile apps. AIs can be compared through all interfaces.

The rules of the game are:

  • Each player has n = 5 pieces on a 2n + 1 by 2n + 1 board represented as a grid.
  • Each piece has 3 life and does 1 damage initially. Both of these are increased by one when a piece levels up.
  • Each player can optionally move any of their pieces one space in the 8 cardinal directions on the grid per turn.
  • Collisions between pieces cause units to damage all contacting enemy units equal to their damage attribute.
  • Pieces are removed from the board, or destroyed, if they have taken damage greater than or equal to their life attribute.
  • Pieces gain a level when they participate in destroying another piece, allowing their damage and life to be boosted by a fixed amount.
  • Players with no pieces at the end of a turn lose.
  • Each player has 30 seconds to make a move each turn.

Installation

Run make to build all interfaces. More specifically:

  • make run_cli: Builds the CLI app.
  • make run_web: Builds the web app.
  • make mobile: Builds the mobile apps.

Documentation

Tests

Run tests with sh run_tests.sh. Pass the --bench flag to also run benchmarks.

Running

Run the CLI with landgrab_run_cli after running make run_cli. Accepted flags are:

  • --wait: Prompt the user to press enter before the next turn. Defaults to true.
  • --player1: Don't prompt the user for a player one and use this instead.
  • --player2: Don't prompt the user for a player two and use this instead.

Run the web application with landgrab_run_web after running make run_web. Accepted flags are:

  • --host:
  • --port:

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  landgrab: "^0.0.1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:landgrab/landgrab.dart';
  
Version Uploaded Documentation Archive
0.0.1 Apr 24, 2017 Go to the documentation of landgrab 0.0.1 Download landgrab 0.0.1 archive

Analysis

We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
99 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
61 / 100
Overall score:
Weighted score of the above. [more]
42
Learn more about scoring.

Platforms

Detected platforms: web

Primary library: package:landgrab/landgrab.dart with components: html.

Suggestions

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Homepage does not exists.

    We were unable to access http://landgrab.jwowillo.com at the time of the analysis.

  • Package is getting outdated.

    The package was released 60 weeks ago.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 6 hints.

    Strong-mode analysis of lib/src/component/board/component.dart gave the following hint:

    line: 57 col: 18
    'MILLISECONDS_PER_SECOND' is deprecated and shouldn't be used.

    Strong-mode analysis of lib/src/service/api.dart gave the following hint:

    line: 42 col: 12
    'JSON' is deprecated and shouldn't be used.

    Similar analysis of the following files failed:

    • lib/src/service/convert.dart (hint)
    • lib/src/service/players.dart (hint)
    • lib/src/service/schema.dart (hint)
  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use landgrab.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0
angular2 ^2.2.0 2.2.0 3.1.0+1
cookie ^0.0.4 0.0.4
Transitive dependencies
analyzer 0.29.5 0.32.1
args 0.13.7 1.4.3
async 1.13.3 2.0.7
barback 0.15.2+16
build 0.5.0 0.12.6
charcode 1.1.1
cli_util 0.1.3
code_transformers 0.5.1+5
collection 1.14.10
convert 2.0.1
crypto 2.0.5
csslib 0.14.4
dart_style 0.2.16 1.1.0
fixnum 0.10.7
glob 1.1.5
html 0.13.3+1
http_parser 3.1.2
intl 0.14.0 0.15.6
isolate 0.2.3 2.0.1
js 0.6.1
logging 0.11.3+1
meta 1.1.5
mime 0.9.6+1
observable 0.14.0+1 0.22.1+3
package_config 1.0.3
path 1.6.1
plugin 0.2.0+2
pool 1.3.5
protobuf 0.5.5 0.9.0
shelf 0.6.8 0.7.3+1
shelf_static 0.2.7+1
source_maps 0.10.5
source_span 1.4.0
stack_trace 1.9.2
stream_channel 1.6.7+1
string_scanner 1.0.2
typed_data 1.1.5
utf 0.9.0+4
watcher 0.9.7+8
yaml 2.1.14
Dev dependencies
browser ^0.10.0
dart_to_js_script_rewriter ^1.0.1