lb_logger 0.0.2

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 0

lb_logger

Redis-based logger for Dart, named in honour of Lars Bak.

Usage

See example/lb_logger_test.dart

Features and bugs

Please file feature requests and bugs at the issue tracker.

0.0.1

  • Initial version, created by Stagehand

example/lb_logger_example.dart

import 'package:redis_client/redis_client.dart';
import 'package:lb_logger/lb_logger.dart';

main() async {
  RedisClient redisClient = await RedisClient.connect();
  RedisLogger logger = new RedisLogger(redisClient, 'mylogger');
  print('logger ${logger.name}');
  redisClient.close();
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  lb_logger: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:lb_logger/lb_logger.dart';
  
Version Uploaded Documentation Archive
0.0.2 Jul 4, 2018 Go to the documentation of lb_logger 0.0.2 Download lb_logger 0.0.2 archive
0.0.1 Jul 4, 2018 Go to the documentation of lb_logger 0.0.1 Download lb_logger 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0