legit 0.1.0

  • README.md
  • Installing
  • Versions
  • 0


Legit is a Git Library for Dart.


List Commits

import "package:legit/legit.dart";

main() async {
  var git = new GitClient.forCurrentDirectory();

  var commits = await git.listCommits();
  for (var commit in commits) {
    print("- " + commit.message);
    print("  By: ${commit.author.name} <${commit.author.email}>");
    print("  SHA: ${commit.sha}");

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  legit: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:legit/legit.dart';
Version Uploaded Documentation Archive
0.1.0 May 10, 2016 Go to the documentation of legit 0.1.0 Download legit 0.1.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jan 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.10


Detected platforms:

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.1.0.
 Because legit depends on crypto >=0.5.13 <2.0.6 which requires SDK version >=0.5.13 <2.0.0-∞, version solving failed.

Health suggestions

Format lib/id.dart.

Run dartfmt to format lib/id.dart.

Format lib/io.dart.

Run dartfmt to format lib/io.dart.

Format lib/raw.dart.

Run dartfmt to format lib/raw.dart.

Format lib/src/client.dart.

Run dartfmt to format lib/src/client.dart.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Package is too old. (-100 points)

The package was released more than two years ago.

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example.

None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use legit.dart. Packages with multiple examples should use example/readme.md.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.13.0