legit 0.1.0

  • README.md
  • Installing
  • Versions
  • 22

Legit

Legit is a Git Library for Dart.

Examples

List Commits

import "package:legit/legit.dart";

main() async {
  var git = new GitClient.forCurrentDirectory();

  var commits = await git.listCommits();
  for (var commit in commits) {
    print("- " + commit.message);
    print("  By: ${commit.author.name} <${commit.author.email}>");
    print("  SHA: ${commit.sha}");
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  legit: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:legit/legit.dart';
  
Version Uploaded Documentation Archive
0.1.0 May 10, 2016 Go to the documentation of legit 0.1.0 Download legit 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
72
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
22
Learn more about scoring.

We analyzed this package on Jul 20, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.69.0
  • pana: 0.11.7

Platforms

Detected platforms: Flutter, other

Primary library: package:legit/legit.dart with components: io.

Issues and suggestions

Fix lib/io.dart.

Analysis of lib/io.dart failed with 1 error, 2 hints:

line 61 col 35: The argument type 'BetterProcessResult' can't be assigned to the parameter type 'Process'.

line 7 col 8: Unused import: 'id.dart'.

line 107 col 53: 'APPEND' is deprecated and shouldn't be used.

Maintain CHANGELOG.md.

Changelog entries help clients to follow the progress in your code.

Package is too old.

The package was released more than two years ago.

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v1 release.

While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction of the API.

Fix lib/raw.dart.

Analysis of lib/raw.dart reported 6 hints, including:

line 24 col 21: 'SHA1' is deprecated and shouldn't be used.

line 25 col 11: 'add' is deprecated and shouldn't be used.

line 26 col 18: 'CryptoUtils' is deprecated and shouldn't be used.

line 26 col 45: 'close' is deprecated and shouldn't be used.

line 58 col 20: 'ZLIB' is deprecated and shouldn't be used.

Fix lib/id.dart.

Analysis of lib/id.dart reported 1 hint:

line 64 col 20: The top level variable '_specials' isn't used.

Format lib/src/client.dart.

Run dartfmt to format lib/src/client.dart.

Maintain an example.

None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use legit.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.13.0
crypto ^0.9.1 0.9.2+1 2.0.6
path ^1.3.9 1.6.2
Transitive dependencies
charcode 1.1.2
convert 1.1.1 2.0.2
typed_data 1.1.6