libphonenumber 0.0.4

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 87

libphonenumber #

This is a Flutter implementation of libphonenumber. It includes only a few features at the moment, and are added when more functionality is desired.

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing plugin code, view the documentation.

0.0.4 #

  • Another iOS fix, this time for getRegionInfo

0.0.3 #

  • iOS fix for parsing phone numbers

0.0.2 #

  • Fix Android package name issue

0.0.1 #

  • Initial version

example/README.md

libphonenumber_example #

Demonstrates how to use the libphonenumber plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  libphonenumber: ^0.0.4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:libphonenumber/libphonenumber.dart';
  
Version Uploaded Documentation Archive
0.0.4 Jan 2, 2019 Go to the documentation of libphonenumber 0.0.4 Download libphonenumber 0.0.4 archive
0.0.3 Dec 17, 2018 Go to the documentation of libphonenumber 0.0.3 Download libphonenumber 0.0.3 archive
0.0.2 Dec 8, 2018 Go to the documentation of libphonenumber 0.0.2 Download libphonenumber 0.0.2 archive
0.0.1 Dec 5, 2018 Go to the documentation of libphonenumber 0.0.1 Download libphonenumber 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
79
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
87
Learn more about scoring.

We analyzed this package on Feb 14, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.13
  • Flutter: 1.2.0

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

14 out of 14 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/libphonenumber.dart.

Run flutter format to format lib/libphonenumber.dart.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8